Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "MessagePack implementation for C and C++" |
| 2 | DESCRIPTION = "MessagePack is an efficient binary serialization format. It's like JSON. but fast and small" |
| 3 | HOMEPAGE = "http://msgpack.org/index.html" |
| 4 | LICENSE = "BSL-1.0" |
| 5 | LIC_FILES_CHKSUM = "file://NOTICE;md5=7a858c074723608e08614061dc044352 \ |
| 6 | file://COPYING;md5=0639c4209b6f2abf1437c813b208f2d3 \ |
| 7 | file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c \ |
| 8 | " |
| 9 | |
| 10 | SRC_URI = "https://github.com/msgpack/msgpack-c/releases/download/cpp-${PV}/msgpack-cxx-${PV}.tar.gz" |
| 11 | SRC_URI[sha256sum] = "8115c5edcf20bc1408c798a6bdaec16c1e52b1c34859d4982a0fb03300438f0b" |
| 12 | |
| 13 | S = "${WORKDIR}/msgpack-cxx-${PV}" |
| 14 | |
| 15 | DEPENDS += "boost" |
| 16 | |
| 17 | inherit cmake pkgconfig |
| 18 | |
| 19 | RDEPENDS:${PN}-dev = "" |
| 20 | |
| 21 | BBCLASSEXTEND += "native nativesdk" |