Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "AppStream is a collaborative effort for making machine-readable software metadata easily available." |
| 2 | HOMEPAGE = "https://github.com/ximion/appstream" |
| 3 | LICENSE = "LGPL-2.1-only" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=435ed639f84d4585d93824e7da3d85da" |
| 5 | |
| 6 | DEPENDS = " \ |
| 7 | appstream-native \ |
| 8 | curl-native \ |
| 9 | curl \ |
| 10 | docbook-xml-dtd4-native \ |
| 11 | gperf-native \ |
| 12 | glib-2.0 \ |
| 13 | libyaml \ |
| 14 | libstemmer \ |
| 15 | libxml2 \ |
| 16 | libxmlb \ |
| 17 | libxslt-native \ |
| 18 | itstool-native \ |
| 19 | docbook-xsl-stylesheets-native \ |
| 20 | python3-pygments-native \ |
| 21 | " |
| 22 | |
| 23 | inherit meson gobject-introspection gettext gtk-doc pkgconfig vala |
| 24 | |
| 25 | GIR_MESON_OPTION = "" |
| 26 | |
| 27 | SRC_URI = "https://www.freedesktop.org/software/appstream/releases/AppStream-${PV}.tar.xz" |
| 28 | SRC_URI:append:class-target = " file://0001-fix-crosscompile.patch" |
| 29 | SRC_URI[sha256sum] = "cb15ed62cc2729683879a2dbf98c0a3267ea2b4d57bba6bc55e70a25500e04c2" |
| 30 | |
| 31 | S = "${WORKDIR}/AppStream-${PV}" |
| 32 | |
| 33 | FILES:${PN} += "${datadir}" |
| 34 | |
| 35 | EXTRA_OEMESON:class-target += "--cross-file=${WORKDIR}/meson-${PN}.cross" |
| 36 | |
| 37 | do_write_config:append:class-target() { |
| 38 | cat >${WORKDIR}/meson-${PN}.cross <<EOF |
| 39 | [binaries] |
| 40 | appstreamcli = '${STAGING_BINDIR_NATIVE}/appstreamcli' |
| 41 | EOF |
| 42 | } |
| 43 | |
| 44 | BBCLASSEXTEND = "native" |