Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "A portable version of the mg maintained by the OpenBSD team" |
| 2 | HOMEPAGE = "http://homepage.boetes.org/software/mg/" |
| 3 | LICENSE = "PD" |
| 4 | LIC_FILES_CHKSUM = "file://version.c;md5=43616508f42ab3fdb082c5f932bd2eb4" |
| 5 | DEPENDS = "ncurses libbsd" |
| 6 | SECTION = "console/editors" |
| 7 | |
| 8 | SRCREV = "5dbacce10b4cc5fe0785840c09398fc5b19fb96a" |
| 9 | SRC_URI = "git://github.com/hboetes/mg;branch=master;protocol=https \ |
| 10 | file://0001-fileio-Include-sys-param.h-for-MAXNAMLEN.patch \ |
| 11 | file://0002-fileio-Define-DEFFILEMODE-if-platform-is-missing.patch \ |
| 12 | " |
| 13 | SRC_URI:append:libc-musl = "\ |
| 14 | file://0001-Undefine-REGEX-for-musl-based-systems.patch \ |
| 15 | " |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | # CFLAGS isn't in EXTRA_OEMAKE, as the makefile picks it up via ?= |
| 20 | EXTRA_OEMAKE = "\ |
| 21 | 'CC=${CC}' \ |
| 22 | 'LDFLAGS=${LDFLAGS}' \ |
| 23 | \ |
| 24 | 'prefix=${prefix}' \ |
| 25 | 'bindir=${bindir}' \ |
| 26 | 'libdir=${libdir}' \ |
| 27 | 'includedir=${includedir}' \ |
| 28 | 'mandir=${mandir}' \ |
| 29 | 'PKG_CONFIG=pkg-config' \ |
| 30 | " |
| 31 | |
| 32 | CFLAGS += "-I${STAGING_INCDIR}/bsd" |
| 33 | |
| 34 | do_install () { |
| 35 | oe_runmake install DESTDIR=${D} |
| 36 | } |
| 37 | |
| 38 | inherit pkgconfig |