Ken Chen | a187e71 | 2018-01-15 14:36:21 +0800 | [diff] [blame] | 1 | SUMMARY = "Qualcomm Rep board wiring" |
| 2 | DESCRIPTION = "Board wiring information for the Qualcomm Rep system." |
| 3 | PR = "r1" |
Brad Bishop | 9921ced | 2018-11-07 12:50:34 -0800 | [diff] [blame] | 4 | LICENSE = "Apache-2.0" |
Brad Bishop | c3a3b64 | 2019-09-13 14:02:27 -0400 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Ken Chen | a187e71 | 2018-01-15 14:36:21 +0800 | [diff] [blame] | 6 | |
| 7 | inherit allarch |
| 8 | inherit setuptools |
| 9 | inherit pythonnative |
Ken Chen | a187e71 | 2018-01-15 14:36:21 +0800 | [diff] [blame] | 10 | |
| 11 | PROVIDES += "virtual/obmc-inventory-data" |
| 12 | RPROVIDES_${PN} += "virtual-obmc-inventory-data" |
| 13 | |
| 14 | DEPENDS += "python" |
| 15 | |
| 16 | S = "${WORKDIR}" |
| 17 | SRC_URI += "file://Centriq2400-rep.py" |
| 18 | |
| 19 | python() { |
| 20 | machine = d.getVar('MACHINE', True).capitalize() + '.py' |
| 21 | d.setVar('_config_in_skeleton', machine) |
| 22 | } |
| 23 | |
| 24 | do_make_setup() { |
| 25 | cp ${S}/${_config_in_skeleton} \ |
| 26 | ${S}/obmc_system_config.py |
| 27 | cat <<EOF > ${S}/setup.py |
| 28 | from distutils.core import setup |
| 29 | |
| 30 | setup(name='${BPN}', |
| 31 | version='${PR}', |
| 32 | py_modules=['obmc_system_config'], |
| 33 | ) |
| 34 | EOF |
| 35 | } |
| 36 | |
| 37 | addtask make_setup after do_patch before do_configure |
| 38 | |