blob: 220adaca4a64b3d18c7f1ee2196945c382bff57d [file] [log] [blame]
Ken Chena187e712018-01-15 14:36:21 +08001SUMMARY = "Qualcomm Rep board wiring"
2DESCRIPTION = "Board wiring information for the Qualcomm Rep system."
3PR = "r1"
Brad Bishop9921ced2018-11-07 12:50:34 -08004LICENSE = "Apache-2.0"
Brad Bishopc3a3b642019-09-13 14:02:27 -04005LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Ken Chena187e712018-01-15 14:36:21 +08006
7inherit allarch
8inherit setuptools
9inherit pythonnative
Ken Chena187e712018-01-15 14:36:21 +080010
11PROVIDES += "virtual/obmc-inventory-data"
12RPROVIDES_${PN} += "virtual-obmc-inventory-data"
13
14DEPENDS += "python"
15
16S = "${WORKDIR}"
17SRC_URI += "file://Centriq2400-rep.py"
18
19python() {
20 machine = d.getVar('MACHINE', True).capitalize() + '.py'
21 d.setVar('_config_in_skeleton', machine)
22}
23
24do_make_setup() {
25 cp ${S}/${_config_in_skeleton} \
26 ${S}/obmc_system_config.py
27 cat <<EOF > ${S}/setup.py
28from distutils.core import setup
29
30setup(name='${BPN}',
31 version='${PR}',
32 py_modules=['obmc_system_config'],
33 )
34EOF
35}
36
37addtask make_setup after do_patch before do_configure
38