Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 1 | require ${BPN}.inc |
| 2 | |
| 3 | DEPENDS += " \ |
| 4 | ${BPN}-native \ |
| 5 | glib-2.0-native \ |
| 6 | glib-2.0 \ |
| 7 | dbus \ |
| 8 | iso-codes \ |
| 9 | " |
| 10 | |
| 11 | inherit gtk-icon-cache bash-completion |
| 12 | |
| 13 | # for unicode-ucd |
| 14 | EXTRA_OECONF += "--with-ucd-dir=${STAGING_DATADIR}/unicode/ucd" |
| 15 | |
| 16 | PACKAGECONFIG ??= " \ |
| 17 | dconf vala \ |
| 18 | ${@bb.utils.contains_any('DISTRO_FEATURES', [ 'wayland', 'x11' ], 'gtk3', '', d)} \ |
| 19 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)} \ |
| 20 | " |
| 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | do_configure:prepend() { |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 23 | # run native unicode-parser |
| 24 | sed -i 's:$(builddir)/unicode-parser:unicode-parser:g' ${S}/src/Makefile.am |
| 25 | } |
| 26 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | FILES:${PN} += " \ |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 28 | ${datadir}/dbus-1 \ |
| 29 | ${datadir}/GConf \ |
| 30 | ${datadir}/glib-2.0 \ |
| 31 | ${libdir}/gtk-3.0 \ |
| 32 | " |
| 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | FILES:${PN}-dev += " \ |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 35 | ${datadir}/gettext \ |
| 36 | " |
| 37 | |