Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Host side USB console utilities" |
| 2 | DESCRIPTION = "Contains the lsusb utility for inspecting the devices connected to the USB bus." |
| 3 | HOMEPAGE = "http://www.linux-usb.org" |
| 4 | SECTION = "base" |
| 5 | |
| 6 | LICENSE = "GPLv2+ & (GPLv2 | GPLv3)" |
| 7 | # License files went missing in 010, when 011 is released add LICENSES/* back |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://lsusb.c;endline=1;md5=7226e442a172bcf25807246d7ef1eba1 \ |
| 9 | file://lsusb.py.in;beginline=2;endline=2;md5=c443ada211d701156e42ea36d41625b3 \ |
| 10 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | |
| 12 | DEPENDS = "libusb1 virtual/libiconv udev" |
| 13 | |
| 14 | SRC_URI = "${KERNELORG_MIRROR}/linux/utils/usb/usbutils/usbutils-${PV}.tar.gz \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | " |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "59398ab012888dfe0fd12e447b45f36801e9d7b71d9a865fc38e2f549afdb9d0" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 18 | inherit autotools pkgconfig update-alternatives |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 20 | ALTERNATIVE:${PN} = "lsusb" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | ALTERNATIVE_PRIORITY = "100" |
| 22 | |
| 23 | # The binaries are mostly GPLv2+ apart from lsusb.py which is GPLv2 or v3. |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 24 | LICENSE:${PN} = "GPLv2+" |
| 25 | LICENSE:${PN}-python = "GPLv2 | GPLv3" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 26 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | RRECOMMENDS:${PN} = "udev-hwdb" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | |
| 29 | PACKAGE_BEFORE_PN =+ "${PN}-python" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | FILES:${PN}-python += "${bindir}/lsusb.py" |
| 31 | RDEPENDS:${PN}-python = "python3-core" |