Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "A coroutine-based Python networking library" |
| 2 | DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \ |
| 3 | a high-level synchronous API on top of the libevent event loop." |
| 4 | HOMEPAGE = "http://www.gevent.org" |
| 5 | LICENSE = "MIT & Python-2.0 & BSD" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65 \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | file://NOTICE;md5=18108df3583462cafd457f024b9b09b5 \ |
| 8 | file://deps/libev/LICENSE;md5=d6ad416afd040c90698edcdf1cbee347 \ |
| 9 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | DEPENDS += "libevent" |
| 11 | DEPENDS += "${PYTHON_PN}-greenlet" |
| 12 | RDEPENDS_${PN} = "${PYTHON_PN}-greenlet \ |
| 13 | ${PYTHON_PN}-mime \ |
| 14 | ${PYTHON_PN}-pprint \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 15 | " |
| 16 | |
| 17 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-gevent:" |
| 18 | |
| 19 | SRC_URI_append = " \ |
| 20 | file://libev-conf.patch;patch=1;pnum=1 \ |
| 21 | " |
| 22 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 23 | SRC_URI[md5sum] = "9366ee7eebed48003f8a748568ef1f70" |
| 24 | SRC_URI[sha256sum] = "5f6d48051d336561ec08995431ee4d265ac723a64bba99cc58c3eb1a4d4f5c8d" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 25 | |
| 26 | # The python-gevent has no autoreconf ability |
| 27 | # and the logic for detecting a cross compile is flawed |
| 28 | # so always force a cross compile |
| 29 | do_configure_append() { |
| 30 | sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/libev/configure |
| 31 | sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/c-ares/configure |
| 32 | } |
| 33 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 34 | inherit pypi setuptools3 |