Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Google gRPC" |
| 2 | HOMEPAGE = "http://www.grpc.io/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 6 | |
| 7 | DEPENDS += "${PYTHON_PN}-protobuf" |
| 8 | |
| 9 | SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch" |
| 10 | SRC_URI_append_class-target = " file://ppc-boringssl-support.patch \ |
| 11 | file://riscv64_support.patch \ |
Andrew Geissler | e231d58 | 2020-05-05 08:53:09 -0500 | [diff] [blame] | 12 | file://0001-Fix-build-on-riscv32.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | " |
| 14 | SRC_URI[md5sum] = "ccaf4e7eb4f031d926fb80035d193b98" |
| 15 | SRC_URI[sha256sum] = "a899725d34769a498ecd3be154021c4368dd22bdc69473f6ec46779696f626c4" |
| 16 | |
| 17 | RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \ |
| 18 | ${PYTHON_PN}-setuptools \ |
| 19 | ${PYTHON_PN}-six \ |
| 20 | " |
| 21 | |
| 22 | inherit setuptools3 |
| 23 | inherit pypi |
| 24 | |
| 25 | export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1" |
| 26 | |
| 27 | do_compile_prepend_toolchain-clang() { |
| 28 | export GRPC_PYTHON_CFLAGS='-fvisibility=hidden -fno-wrapv -fno-exceptions' |
| 29 | } |
| 30 | |
| 31 | CLEANBROKEN = "1" |
| 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |
| 34 | |
| 35 | CCACHE_DISABLE = "1" |