Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 1 | SUMMARY = "view/edit your binary with any text editor" |
| 2 | |
| 3 | # The homepage listed on pypi is [1] but the repository has been removed. |
| 4 | # Instead, set the homepage to pypi. |
| 5 | # |
| 6 | # [1] https://bitbucket.org/techtonik/hexdump/ |
| 7 | HOMEPAGE = "https://pypi.org/project/hexdump/" |
| 8 | |
| 9 | LICENSE = "PD" |
| 10 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/PD;md5=b3597d12946881e13cb3b548d1173851" |
| 11 | |
| 12 | PYPI_PACKAGE_EXT = "zip" |
| 13 | |
| 14 | inherit pypi distutils3 |
| 15 | |
| 16 | SRC_URI[sha256sum] = "d781a43b0c16ace3f9366aade73e8ad3a7bd5137d58f0b45ab2d3f54876f20db" |
| 17 | |
| 18 | S = "${WORKDIR}" |
| 19 | |
| 20 | BBCLASSEXTEND = "native nativesdk" |
| 21 | |
| 22 | do_cleanup_hexfile() { |
| 23 | rm ${D}${datadir}/data/hexfile.bin |
| 24 | rmdir ${D}${datadir}/data ${D}${datadir} |
| 25 | } |
| 26 | |
| 27 | addtask cleanup_hexfile before do_package after do_install |