Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "A Python implementation of Google's Encoded Polyline Algorithm Format" |
| 2 | HOMEPAGE = "https://pypi.org/project/polyline/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0fbd13500cabd06dd751ba6b2be304c6" |
| 5 | |
| 6 | SRC_URI[md5sum] = "b97c57378605c4a856c437569f95a0cb" |
| 7 | SRC_URI[sha256sum] = "7c7f89d09a09c7b6161bdbfb4fd304b186fc7a2060fa4f31cb3f61c646a5c074" |
| 8 | |
| 9 | inherit pypi setuptools3 ptest |
| 10 | |
| 11 | RDEPENDS_${PN} += "python3-six" |
| 12 | |
| 13 | BBCLASSEXTEND = "native nativesdk" |
| 14 | |
| 15 | SRC_URI += " \ |
| 16 | file://run-ptest \ |
| 17 | " |
| 18 | |
| 19 | RDEPENDS_${PN}-ptest += " \ |
| 20 | ${PYTHON_PN}-pytest \ |
| 21 | " |
| 22 | |
| 23 | do_install_ptest() { |
| 24 | install -d ${D}${PTEST_PATH}/test |
| 25 | cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/ |
| 26 | } |