Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "A toolkit to write, run and analyze benchmarks" |
| 2 | DESCRIPTION = " \ |
| 3 | The Python pyperf module is a toolkit to write, run and analyze benchmarks. \ |
| 4 | Features: \ |
| 5 | * Simple API to run reliable benchmarks \ |
| 6 | * Automatically calibrate a benchmark for a time budget. \ |
| 7 | * Spawn multiple worker processes. \ |
| 8 | * Compute the mean and standard deviation. \ |
| 9 | * Detect if a benchmark result seems unstable. \ |
| 10 | * JSON format to store benchmark results. \ |
| 11 | * Support multiple units: seconds, bytes and integer. \ |
| 12 | " |
| 13 | LICENSE = "MIT" |
| 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8" |
| 15 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "1257d673d89fdcdbaec8077afeb365e7a94739c1b263572b09403cac25708ad3" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | |
| 18 | DEPENDS += "${PYTHON_PN}-six-native" |
| 19 | |
| 20 | PYPI_PACKAGE = "pyperf" |
| 21 | inherit pypi setuptools3 |
| 22 | |
| 23 | RDEPENDS_${PN} += "${PYTHON_PN}-misc" |