blob: b57ea16eba9d22b2b13e58bf571496adbbe4350c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A toolkit to write, run and analyze benchmarks"
2DESCRIPTION = " \
3The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
4Features: \
5 * Simple API to run reliable benchmarks \
6 * Automatically calibrate a benchmark for a time budget. \
7 * Spawn multiple worker processes. \
8 * Compute the mean and standard deviation. \
9 * Detect if a benchmark result seems unstable. \
10 * JSON format to store benchmark results. \
11 * Support multiple units: seconds, bytes and integer. \
12"
13LICENSE = "MIT"
14LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
15
Andrew Geisslereef63862021-01-29 15:58:13 -060016SRC_URI[sha256sum] = "1257d673d89fdcdbaec8077afeb365e7a94739c1b263572b09403cac25708ad3"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18DEPENDS += "${PYTHON_PN}-six-native"
19
20PYPI_PACKAGE = "pyperf"
21inherit pypi setuptools3
22
23RDEPENDS_${PN} += "${PYTHON_PN}-misc"