Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 1 | SUMMARY = "Chassis Power Control service for Intel based platforms" |
| 2 | DESCRIPTION = "Chassis Power Control service for Intel based platforms" |
| 3 | |
| 4 | SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=ssh" |
Andrew Geissler | 01bd175 | 2021-10-07 15:42:05 +0000 | [diff] [blame] | 5 | SRCREV = "f3a33b41348f9f7def1928699d1b356a1d132df5" |
Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 6 | |
| 7 | PV = "1.0+git${SRCPV}" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | LICENSE = "Apache-2.0" |
| 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 13 | |
| 14 | inherit cmake systemd |
Vijay Khemka | a5bc17f | 2020-06-12 16:26:47 -0700 | [diff] [blame] | 15 | inherit obmc-phosphor-dbus-service |
Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 16 | |
Andrew Geissler | 9e6f034 | 2021-07-15 06:51:21 +0000 | [diff] [blame] | 17 | def get_service(d): |
| 18 | if(d.getVar('OBMC_HOST_INSTANCES') == '0'): |
| 19 | return "xyz.openbmc_project.Chassis.Control.Power@0.service" |
| 20 | else: |
| 21 | return " ".join(["xyz.openbmc_project.Chassis.Control.Power@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()]) |
| 22 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 23 | SYSTEMD_SERVICE:${PN} = "${@get_service(d)}" |
Andrew Geissler | 9e6f034 | 2021-07-15 06:51:21 +0000 | [diff] [blame] | 24 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 25 | SYSTEMD_SERVICE:${PN} += "chassis-system-reset.service \ |
Vijay Khemka | 6dfddb4 | 2020-05-21 16:52:57 -0700 | [diff] [blame] | 26 | chassis-system-reset.target" |
Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 27 | |
| 28 | DEPENDS += " \ |
| 29 | boost \ |
| 30 | i2c-tools \ |
| 31 | libgpiod \ |
Priyatharshan P | 9691eaa | 2020-06-30 19:57:55 +0530 | [diff] [blame] | 32 | nlohmann-json \ |
Vijay Khemka | e810c50 | 2019-10-30 10:31:48 -0700 | [diff] [blame] | 33 | sdbusplus \ |
| 34 | phosphor-logging \ |
| 35 | " |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 36 | FILES:${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.Chassis.Control.Power@.service" |