Joel Stanley | 7259c7d | 2019-11-04 23:43:51 +1030 | [diff] [blame^] | 1 | SUMMARY = "eCMD" |
| 2 | DESCRIPTION = "eCMD is a hardware access API for IBM Systems" |
| 3 | LICENSE= "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${S}/NOTICE;md5=fee220301a2af3faf8f211524b4248ea" |
| 5 | |
| 6 | SRC_URI = "git://github.com/open-power/eCMD.git" |
| 7 | SRCREV = "6c0348b12c95b3bd6e8d8003f9ff743d25400ae2" |
| 8 | DEPENDS += "python-native zlib" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | # Add the hash style option here to Work around this warning: |
| 13 | # "QA Issue: No GNU_HASH in the elf binary" |
| 14 | # |
| 15 | # The recipe cannot set LDFLAGS in the environment as it overrides the |
| 16 | # internal settings. |
| 17 | do_configure() { |
| 18 | LD="${CXX} -Wl,--hash-style=gnu" ${S}/config.py --without-swig --output-root ${B} --target obj --extensions "cmd cip" --build-verbose |
| 19 | } |
| 20 | |
| 21 | do_compile() { |
| 22 | cd ${S}/dllNetwork/server |
| 23 | oe_runmake |
| 24 | } |
| 25 | |
| 26 | do_install() { |
| 27 | install -d ${D}${bindir} |
| 28 | install -m 0755 out_obj/lib/server1p ${D}${bindir}/croserver |
| 29 | } |