Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 1 | SUMMARY = "Simple web browser" |
| 2 | DESCRIPTION = "Simple open source web browser based on WebKit2/GTK" |
| 3 | HOMEPAGE = "https://surf.suckless.org/" |
| 4 | SECTION = "x11/graphics" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b57e7f7720307a02d5a6598b00fe3afa" |
| 7 | |
| 8 | DEPENDS = "webkitgtk gtk+3 glib-2.0" |
| 9 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 10 | REQUIRED_DISTRO_FEATURES = "x11 opengl" |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 11 | |
| 12 | SRC_URI = "git://git.suckless.org/surf;branch=surf-webkit2 \ |
| 13 | file://0001-config.mk-Fix-compiler-and-linker.patch \ |
| 14 | " |
| 15 | SRCREV = "b814567e2bf8bda07cea8de1c7a062f4aa437b65" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 19 | inherit pkgconfig features_check |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 20 | |
| 21 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 22 | |
| 23 | do_install () { |
| 24 | install -D -m 0755 ${S}/surf ${D}${bindir}/surf |
| 25 | } |