blob: 333b015a96f703855668459e7eb3853c457d98a7 [file] [log] [blame]
Andrew Geissler89770b02020-06-13 10:40:47 -05001SUMMARY = "Physical quantities module"
2DESCRIPTION = "Physical quantities Python module"
3HOMEPAGE = "https://github.com/hgrecco/pint"
4SECTION = "devel/python"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
8
9PYPI_PACKAGE := "Pint"
10
11inherit pypi ptest setuptools3
12
Andrew Geisslerd221e032020-07-10 16:13:21 -050013SRC_URI[md5sum] = "e5e409806bc82f518230117b30ae23ed"
14SRC_URI[sha256sum] = "9aa450ebb9d722ed03fa9a450104cfd16c479b49f862d547c6f77320de597f72"
Andrew Geissler89770b02020-06-13 10:40:47 -050015
16DEPENDS += "python3-setuptools-scm-native"
17
18BBCLASSEXTEND = "native nativesdk"
19
20SRC_URI += " \
21 file://run-ptest \
22"
23
Andrew Geissler748a4832020-07-24 16:24:21 -050024RDEPENDS_${PN} += " \
25 ${PYTHON_PN}-setuptools \
26 ${PYTHON_PN}-packaging \
27"
28
Andrew Geissler89770b02020-06-13 10:40:47 -050029RDEPENDS_${PN}-ptest += " \
30 ${PYTHON_PN}-pytest \
31"
32
33do_install_ptest() {
34 install -d ${D}${PTEST_PATH}/testsuite
35 cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
36}