blob: 442c1a3c62cdb722a0759813bdf1c6ecb11ce2ae [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenGL driver testing framework"
Brad Bishop1d80a2e2019-11-15 16:35:03 -05002DESCRIPTION = "Piglit is an open-source test suite for OpenGL and OpenCL \
3implementations."
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
6
Brad Bishop96ff1982019-08-19 13:50:42 -04007SRC_URI = "git://gitlab.freedesktop.org/mesa/piglit.git;protocol=https \
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008 file://0001-cmake-install-bash-completions-in-the-right-place.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009 file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060010 file://0001-Add-a-missing-include-for-htobe32-definition.patch \
Andrew Geissler09209ee2020-12-13 08:44:15 -060011 file://0001-generated_tests-gen_tcs-tes_input_tests.py-do-not-ha.patch \
12 file://0002-tests-util-piglit-shader.c-do-not-hardcode-build-pat.patch \
13 file://0001-serializer.py-make-.gz-files-reproducible.patch \
14 file://0001-framework-profile.py-make-test-lists-reproducible.patch \
15 file://0001-tests-shader.py-sort-the-file-list-before-working-on.patch \
Andrew Geisslerc723b722021-01-08 16:14:09 -060016 file://0001-render-ops.c-add-missing-format-string.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060017 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040018UPSTREAM_CHECK_COMMITS = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019
Andrew Geisslerc723b722021-01-08 16:14:09 -060020SRCREV = "603deba4ab66e2a8948693a14d715e536caddcc5"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021# (when PV goes above 1.0 remove the trailing r)
22PV = "1.0+gitr${SRCPV}"
23
24S = "${WORKDIR}/git"
25
Brad Bishopc342db32019-05-15 21:57:59 -040026X11_DEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxrender libglu', '', d)}"
27X11_RDEPS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'mesa-demos', '', d)}"
28
29DEPENDS = "libpng waffle libxkbcommon virtual/libgl python3-mako-native python3-numpy-native python3-six-native virtual/egl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030
Brad Bishop6dbb3162019-11-25 09:41:34 -050031inherit cmake pkgconfig python3native features_check bash-completion
Patrick Williamsc124f4f2015-09-15 14:41:29 -050032
Brad Bishop6e60e8b2018-02-01 10:27:11 -050033# depends on virtual/libgl
34REQUIRED_DISTRO_FEATURES += "opengl"
35
Patrick Williamsf1e5d692016-03-30 15:21:19 -050036# The built scripts go into the temporary directory according to tempfile
37# (typically /tmp) which can race if multiple builds happen on the same machine,
38# so tell it to use a directory in ${B} to avoid overwriting.
39export TEMP = "${B}/temp/"
40do_compile[dirs] =+ "${B}/temp/"
41
Brad Bishopc342db32019-05-15 21:57:59 -040042PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
Brad Bishopc342db32019-05-15 21:57:59 -040044PACKAGECONFIG[x11] = "-DPIGLIT_BUILD_GL_TESTS=ON,-DPIGLIT_BUILD_GL_TESTS=OFF,${X11_DEPS}, ${X11_RDEPS}"
45
Andrew Geissler09209ee2020-12-13 08:44:15 -060046export PIGLIT_BUILD_DIR = "../../../../git"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050047
48do_configure_prepend() {
49 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
50 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
51 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
52 fi
53}
54
Andrew Geissler82c905d2020-04-13 13:39:40 -050055# Forcibly strip because Piglit is *huge*
Brad Bishop316dfdd2018-06-25 12:45:53 -040056OECMAKE_TARGET_INSTALL = "install/strip"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060057
Brad Bishopa5c52ff2018-11-23 10:55:50 +130058RDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
Brad Bishop316dfdd2018-06-25 12:45:53 -040059 python3-misc \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060060 python3-unixadmin python3-xml python3-multiprocessing \
Brad Bishop316dfdd2018-06-25 12:45:53 -040061 python3-six python3-shell python3-io \
Brad Bishopc342db32019-05-15 21:57:59 -040062 python3-netserver bash \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050063 "
64
Patrick Williamsc0f7c042017-02-23 20:41:17 -060065INSANE_SKIP_${PN} += "dev-so already-stripped"
Brad Bishop19323692019-04-05 15:28:33 -040066
Andrew Geissler82c905d2020-04-13 13:39:40 -050067# As nothing builds against Piglit we don't need to have anything in the
68# sysroot, especially when this is ~2GB of test suite
69SYSROOT_DIRS_remove = "${libdir}"
70
Brad Bishop19323692019-04-05 15:28:33 -040071# Can't be built with ccache
72CCACHE_DISABLE = "1"