Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 1 | SUMMARY = "Python utilities for working with Ethereum ABI definitions, especially encoding and decoding." |
| 2 | HOMEPAGE = "https://github.com/ethereum/eth-abi" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bf9691ead96f1163622689e47ce3f366" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "31578b179cf9430c21ac32a4e5f401c14b6e2cc1fd64ca3587cd354068217804" |
| 8 | |
| 9 | PYPI_PACKAGE = "eth_abi" |
| 10 | |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | RDEPENDS:${PN} += " \ |
| 14 | python3-eth-typing \ |
| 15 | python3-eth-utils \ |
| 16 | python3-parsimonious \ |
| 17 | python3-setuptools \ |
| 18 | " |