Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 1 | SUMMARY = "Python interface to Linux uinput kernel module." |
| 2 | HOMEPAGE = "https://pypi.org/project/python-uinput/" |
| 3 | LICENSE = "GPL-3.0-only" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949" |
| 5 | |
| 6 | SRC_URI += "file://0001-setup-use-setuptools-instead-of-distutils.patch \ |
| 7 | file://0001-Deal-with-64bit-time_t-default-on-32bit-architecture.patch \ |
| 8 | " |
| 9 | SRC_URI[sha256sum] = "99392b676c77b5795b86b7d75274db33fe754fd1e06fb3d58b167c797dc47f0c" |
| 10 | |
| 11 | PYPI_PACKAGE = "python-uinput" |
| 12 | |
| 13 | inherit pypi setuptools3 |
| 14 | |
| 15 | DEPENDS += "udev" |
| 16 | RDEPENDS:${PN} += " \ |
| 17 | python3-ctypes \ |
| 18 | python3-distutils \ |
| 19 | " |
| 20 | RRECOMMENDS:${PN} += "kernel-module-uinput" |