Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Command-line programs to safely lock and unlock files and mailboxes" |
| 2 | DESCRIPTION = "\ |
| 3 | lockfile-progs provide a method to lock and unlock mailboxes and files \ |
| 4 | safely (via liblockfile)." |
| 5 | HOMEPAGE = "http://packages.qa.debian.org/l/lockfile-progs.html" |
| 6 | SECTION = "Applications/System" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 7 | LICENSE = "GPL-2.0-only" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" |
| 9 | DEPENDS = "liblockfile" |
| 10 | |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 11 | SRC_URI = "${DEBIAN_MIRROR}/main/l/${BPN}/${BPN}_${PV}.tar.gz" |
William A. Kennington III | 49e9566 | 2021-09-15 16:19:36 -0700 | [diff] [blame] | 12 | SRC_URI[sha256sum] = "2c5704b01c8f474f82921780e4592a927b2bf6a6d7616354a6c5d7cd5664857e" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 13 | |
| 14 | do_compile() { |
| 15 | oe_runmake CFLAGS=' -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -fasynchronous-unwind-tables' |
| 16 | } |
| 17 | |
| 18 | do_install() { |
| 19 | install -m 755 -d ${D}${bindir} |
| 20 | install bin/* ${D}${bindir} |
| 21 | install -m 755 -d ${D}${mandir}/man1 |
| 22 | install man/* ${D}${mandir}/man1 |
| 23 | } |