Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "openpyxl is a Python library to read/write Excel 2010 xlsx/xlsm/xltx/xltm files" |
| 2 | DESCRIPTION = "It was born from lack of existing library to read/write natively \ |
| 3 | from Python the Office Open XML format. All kudos to the PHPExcel team as openpyxl \ |
| 4 | was initially based on PHPExcel." |
| 5 | |
| 6 | HOMEPAGE = "http://www.python-excel.org/" |
| 7 | LICENSE = "MIT" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | |
| 10 | inherit pypi setuptools3 |
| 11 | |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 12 | SRC_URI[sha256sum] = "4f2770348c029ce9433316ced8f91ed37d2a605e654f8bfdc93a3524561a8ce2" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 14 | RDEPENDS:${PN} += "\ |
| 15 | ${PYTHON_PN}-compression \ |
| 16 | ${PYTHON_PN}-io \ |
| 17 | ${PYTHON_PN}-pprint \ |
| 18 | ${PYTHON_PN}-shell \ |
| 19 | ${PYTHON_PN}-jdcal \ |
| 20 | ${PYTHON_PN}-et-xmlfile \ |
| 21 | ${PYTHON_PN}-numbers \ |
| 22 | ${PYTHON_PN}-xml \ |
| 23 | " |