blob: 823bea77e3f3974caf661d592e1da65ffa3a3094 [file] [log] [blame]
Thang Q. Nguyen75429292021-07-06 08:49:17 +00001SUMMARY = "Altra Boot Progress Handling Service"
2DESCRIPTION = "OpenBMC Altra Boot Progress Handling Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
11DEPENDS += "systemd"
12RDEPENDS:${PN} += "libsystemd"
13RDEPENDS:${PN} += "bash"
14
15SRC_URI = " \
16 file://ampere_boot_progress.sh \
17 "
18
19SYSTEMD_PACKAGES = "${PN}"
20
21HOST_ON_RESET_HOSTTMPL = "ampere-boot-progress.service"
22HOST_ON_RESET_HOSTINSTMPL = "ampere-boot-progress.service"
23HOST_ON_RESET_HOSTTGTFMT = "obmc-host-already-on@{0}.target"
24HOST_ON_RESET_HOSTFMT = "../${HOST_ON_RESET_HOSTTMPL}:${HOST_ON_RESET_HOSTTGTFMT}.requires/${HOST_ON_RESET_HOSTINSTMPL}"
25SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'HOST_ON_RESET_HOSTFMT', 'OBMC_HOST_INSTANCES')}"
26
27SYSTEMD_SERVICE:${PN} += "${HOST_ON_RESET_HOSTTMPL}"
28
29do_install () {
30 install -d ${D}${sbindir}
31 install -m 0755 ${WORKDIR}/ampere_boot_progress.sh ${D}${sbindir}/
32}
33