Andrew Jeffery | 1b77f28e | 2018-04-06 14:13:14 +0930 | [diff] [blame] | 1 | SUMMARY = "Phosphor IPMI daemon configuration" |
| 2 | PR = "r1" |
Brad Bishop | 75f0387 | 2018-11-03 09:41:57 -0700 | [diff] [blame^] | 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
Andrew Jeffery | 1b77f28e | 2018-04-06 14:13:14 +0930 | [diff] [blame] | 5 | |
Andrew Jeffery | 1b77f28e | 2018-04-06 14:13:14 +0930 | [diff] [blame] | 6 | inherit allarch |
| 7 | |
| 8 | SRC_URI = " \ |
| 9 | file://cipher_list.json \ |
| 10 | file://dcmi_cap.json \ |
| 11 | file://dcmi_sensors.json \ |
| 12 | file://dev_id.json \ |
| 13 | file://power_reading.json \ |
| 14 | " |
| 15 | |
| 16 | FILES_${PN} = " \ |
| 17 | ${datadir}/ipmi-providers/cipher_list.json \ |
| 18 | ${datadir}/ipmi-providers/dcmi_cap.json \ |
| 19 | ${datadir}/ipmi-providers/dcmi_sensors.json \ |
| 20 | ${datadir}/ipmi-providers/dev_id.json \ |
| 21 | ${datadir}/ipmi-providers/power_reading.json \ |
| 22 | " |
| 23 | |
| 24 | do_fetch[noexec] = "1" |
| 25 | do_patch[noexec] = "1" |
| 26 | do_configure[noexec] = "1" |
| 27 | do_compile[noexec] = "1" |
| 28 | |
| 29 | do_install() { |
| 30 | install -d ${D}${datadir}/ipmi-providers |
| 31 | install -m 0644 -D ${WORKDIR}/cipher_list.json \ |
| 32 | ${D}${datadir}/ipmi-providers/cipher_list.json |
| 33 | install -m 0644 -D ${WORKDIR}/dcmi_cap.json \ |
| 34 | ${D}${datadir}/ipmi-providers/dcmi_cap.json |
| 35 | install -m 0644 -D ${WORKDIR}/dcmi_sensors.json \ |
| 36 | ${D}${datadir}/ipmi-providers/dcmi_sensors.json |
| 37 | install -m 0644 -D ${WORKDIR}/dev_id.json \ |
| 38 | ${D}${datadir}/ipmi-providers/dev_id.json |
| 39 | install -m 0644 -D ${WORKDIR}/power_reading.json \ |
| 40 | ${D}${datadir}/ipmi-providers/power_reading.json |
| 41 | } |