Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Utility for viewing/manipulating IDE disk drive/driver parameters" |
| 2 | HOMEPAGE = "http://sourceforge.net/projects/hdparm/" |
| 3 | DESCRIPTION = "hdparm is a Linux shell utility for viewing \ |
| 4 | and manipulating various IDE drive and driver parameters." |
| 5 | SECTION = "console/utils" |
| 6 | |
| 7 | LICENSE = "BSD & GPLv2" |
| 8 | LICENSE_${PN} = "BSD" |
| 9 | LICENSE_${PN}-dbg = "BSD" |
| 10 | LICENSE_wiper = "GPLv2" |
| 11 | |
| 12 | LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=495d03e50dc6c89d6a30107ab0df5b03 \ |
| 13 | file://debian/copyright;md5=a82d7ba3ade9e8ec902749db98c592f3 \ |
| 14 | file://wiper/GPLv2.txt;md5=fcb02dc552a041dee27e4b85c7396067 \ |
| 15 | file://wiper/wiper.sh;beginline=7;endline=31;md5=b7bc642addc152ea307505bf1a296f09" |
| 16 | |
| 17 | |
| 18 | PACKAGES =+ "wiper" |
| 19 | |
| 20 | FILES_wiper = "${bindir}/wiper.sh" |
| 21 | |
| 22 | RDEPENDS_wiper = "bash gawk coreutils" |
| 23 | |
| 24 | SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/${BP}.tar.gz \ |
| 25 | file://wiper.sh-fix-stat-path.patch \ |
| 26 | " |
| 27 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 28 | SRC_URI[sha256sum] = "2c0f9d75cdbeda928a25a128cd3d0b7120445ec0910c0b29d4c1038ed1be777f" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 29 | |
| 30 | EXTRA_OEMAKE = 'STRIP="echo" LDFLAGS="${LDFLAGS}"' |
| 31 | |
| 32 | inherit update-alternatives |
| 33 | |
| 34 | ALTERNATIVE_${PN} = "hdparm" |
| 35 | ALTERNATIVE_LINK_NAME[hdparm] = "${base_sbindir}/hdparm" |
| 36 | ALTERNATIVE_PRIORITY = "100" |
| 37 | |
| 38 | do_install () { |
| 39 | install -d ${D}/${base_sbindir} ${D}/${mandir}/man8 ${D}/${bindir} |
| 40 | oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install |
| 41 | cp ${S}/wiper/wiper.sh ${D}/${bindir} |
| 42 | } |