Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 1 | SUMMARY = "C++11 command line parser" |
| 2 | DESCRIPTION = "A command line parser for C++11 and beyond that provides a rich feature set with a simple and intuitive interface." |
| 3 | HOMEPAGE = "https://github.com/CLIUtils/CLI11" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9ad746b5f49c0fd53c08ca1faff1922c" |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame^] | 6 | SRCREV = "c2ea58c7f9bb2a1da2d3d7f5b462121ac6a07f16" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 7 | PV .= "+git${SRCPV}" |
| 8 | |
| 9 | SRC_URI += "gitsm://github.com/CLIUtils/CLI11;branch=main;protocol=https \ |
| 10 | https://github.com/philsquared/Catch/releases/download/v2.13.7/catch.hpp \ |
| 11 | file://0001-Do-not-download-the-catch-framework-during-configure.patch" |
| 12 | |
| 13 | SRC_URI[sha256sum] = "ea379c4a3cb5799027b1eb451163dff065a3d641aaba23bf4e24ee6b536bd9bc" |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | do_configure:prepend() { |
| 17 | mkdir -p ${S}/tests/catch2 |
| 18 | cp ${DL_DIR}/catch.hpp ${S}/tests/catch2/catch.hpp |
| 19 | } |
| 20 | |
| 21 | inherit cmake |
| 22 | inherit ptest |
| 23 | |
| 24 | # cli11 is a header only C++ library, so the main package will be empty. |
| 25 | RDEPENDS:${PN}-dev = "" |