Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 1 | SUMMARY = "A coroutine-based Python networking library" |
| 2 | DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \ |
| 3 | a high-level synchronous API on top of the libevent event loop." |
| 4 | HOMEPAGE = "http://www.gevent.org" |
| 5 | LICENSE = "MIT & Python-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65" |
| 7 | DEPENDS += "${PYTHON_PN}-greenlet libev libuv c-ares python3-cython-native" |
| 8 | |
| 9 | RDEPENDS:${PN} = "${PYTHON_PN}-greenlet \ |
| 10 | ${PYTHON_PN}-mime \ |
| 11 | ${PYTHON_PN}-pprint \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI += "file://0001-_setuputils.py-Do-not-add-sys_inc_dir.patch" |
| 15 | |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame^] | 16 | SRC_URI[sha256sum] = "1ca01da176ee37b3527a2702f7d40dbc9ffb8cfc7be5a03bfa4f9eec45e55c46" |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 17 | |
| 18 | inherit pypi setuptools3 |
| 19 | |
| 20 | # Don't embed libraries, link to the system provided libs instead |
| 21 | export GEVENTSETUP_EMBED_CARES = "0" |
| 22 | export GEVENTSETUP_EMBED_LIBEV = "0" |
| 23 | export GEVENTSETUP_EMBED_LIBUV = "0" |
| 24 | |
| 25 | do_configure:append() { |
| 26 | # Delete the embedded copies of libraries so we can't accidentally link to them |
| 27 | rm -rf ${S}/deps |
| 28 | |
| 29 | # Delete the generated cython files, as they are all out of date with python 3.11 |
| 30 | rm -rf ${S}/src/gevent/*.c |
| 31 | } |
| 32 | |
| 33 | do_compile:append() { |
| 34 | sed -i -e 's#${WORKDIR}##g' ${S}/src/gevent/*.c ${S}/src/gevent/libev/*.c ${S}/src/gevent/resolver/*.c |
| 35 | } |