Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Library for building powerful interactive command lines in Python" |
| 2 | HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f" |
| 5 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "9ada952c9d1787f52ff6d5f3484d0b4df8952787c087edf6a1f7c2cb1ea88148" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
| 10 | PYPI_PACKAGE = "prompt_toolkit" |
| 11 | |
| 12 | RDEPENDS:${PN} += " \ |
| 13 | ${PYTHON_PN}-core \ |
| 14 | ${PYTHON_PN}-six \ |
| 15 | ${PYTHON_PN}-terminal \ |
| 16 | ${PYTHON_PN}-threading \ |
| 17 | ${PYTHON_PN}-wcwidth \ |
| 18 | ${PYTHON_PN}-datetime \ |
| 19 | ${PYTHON_PN}-shell \ |
| 20 | ${PYTHON_PN}-image \ |
| 21 | ${PYTHON_PN}-asyncio \ |
| 22 | ${PYTHON_PN}-xml \ |
| 23 | " |
| 24 | |
| 25 | BBCLASSEXTEND = "native nativesdk" |