Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Client for Microsoft PPTP VPNs" |
| 2 | DESCRIPTION = "PPTP Client is a Linux, FreeBSD, NetBSD \ |
| 3 | and OpenBSD client for the proprietary Microsoft Point-to-Point \ |
| 4 | Tunneling Protocol, PPTP. Allows connection to a PPTP based \ |
| 5 | Virtual Private Network (VPN) as used by employers and some \ |
| 6 | cable and ADSL internet service providers." |
| 7 | HOMEPAGE = "http://pptpclient.sourceforge.net" |
| 8 | SECTION = "net" |
| 9 | LICENSE = "GPLv2+" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 11 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | inherit perlnative |
| 13 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 14 | SRC_URI = "${SOURCEFORGE_MIRROR}/sourceforge/pptpclient/pptp-${PV}.tar.gz \ |
| 15 | file://options.pptp \ |
| 16 | " |
| 17 | |
| 18 | SRC_URI[md5sum] = "8d25341352fdae5ad5b36b9f18254908" |
| 19 | SRC_URI[sha256sum] = "82492db8e487ce73b182ee7f444251d20c44f5c26d6e96c553ec7093aefb5af4" |
| 20 | |
| 21 | S = "${WORKDIR}/pptp-${PV}" |
| 22 | |
| 23 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 24 | |
| 25 | do_install() { |
| 26 | install -d ${D}${sbindir} ${D}${sysconfdir}/ppp ${D}${mandir}/man8 |
| 27 | install -m 555 pptp ${D}${sbindir} |
| 28 | install -m 644 pptp.8 ${D}${mandir}/man8 |
| 29 | install -m 644 ${WORKDIR}/options.pptp ${D}${sysconfdir}/ppp |
| 30 | } |
| 31 | |
| 32 | RDEPENDS_${PN} = "ppp" |