Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "ModemManager is a daemon controlling broadband devices/connections" |
| 2 | DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections" |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/" |
| 4 | LICENSE = "GPL-2.0 & LGPL-2.1" |
| 5 | LIC_FILES_CHKSUM = " \ |
| 6 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 7 | file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \ |
| 8 | " |
| 9 | |
| 10 | inherit gnomebase gettext systemd vala gobject-introspection bash-completion |
| 11 | |
| 12 | DEPENDS = "glib-2.0 libgudev intltool-native libxslt-native" |
| 13 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 14 | SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz" |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "167e60b26fa05887f87a0b3fb54143d7845e6e4d8c2f2dd93afac059f41e7edf" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | S = "${WORKDIR}/ModemManager-${PV}" |
| 17 | |
| 18 | PACKAGECONFIG ??= "mbim qmi \ |
| 19 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd polkit', d)} \ |
| 20 | " |
| 21 | |
| 22 | PACKAGECONFIG[at] = "--with-at-command-via-dbus" |
| 23 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,," |
| 24 | PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit" |
| 25 | # Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol. |
| 26 | PACKAGECONFIG[mbim] = "--with-mbim,--without-mbim,libmbim" |
| 27 | # Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol. |
| 28 | PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi" |
| 29 | |
| 30 | EXTRA_OECONF = " \ |
| 31 | --with-udev-base-dir=${nonarch_base_libdir}/udev \ |
| 32 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 33 | |
| 34 | FILES_${PN} += " \ |
| 35 | ${datadir}/icons \ |
| 36 | ${datadir}/polkit-1 \ |
| 37 | ${datadir}/dbus-1 \ |
| 38 | ${datadir}/ModemManager \ |
| 39 | ${libdir}/ModemManager \ |
| 40 | ${systemd_unitdir}/system \ |
| 41 | " |
| 42 | |
| 43 | FILES_${PN}-dev += " \ |
| 44 | ${libdir}/ModemManager/*.la \ |
| 45 | " |
| 46 | |
| 47 | FILES_${PN}-staticdev += " \ |
| 48 | ${libdir}/ModemManager/*.a \ |
| 49 | " |
| 50 | |
| 51 | FILES_${PN}-dbg += "${libdir}/ModemManager/.debug" |
| 52 | |
| 53 | SYSTEMD_SERVICE_${PN} = "ModemManager.service" |