Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "TOMOYO Linux tools" |
| 2 | DESCRIPTION = "TOMOYO Linux is a Mandatory Access Control (MAC) implementation \ |
| 3 | for Linux that can be used to increase the security of a system, while also \ |
| 4 | being useful purely as a system analysis tool." |
| 5 | HOMEPAGE = "http://tomoyo.sourceforge.jp/" |
| 6 | SECTION = "System Environment/Kernel" |
| 7 | |
| 8 | SRC_URI = "http://jaist.dl.sourceforge.jp/tomoyo/53357/${BP}-20170102.tar.gz" |
| 9 | SRC_URI[md5sum] = "888804d58742452fe213a68f7eadd0ad" |
| 10 | SRC_URI[sha256sum] = "00fedfac5e514321250bbe69eaccc732c8a8158596f77a785c2e3ae9f9968283" |
| 11 | |
| 12 | S = "${WORKDIR}/${BPN}" |
| 13 | |
| 14 | LICENSE = "GPLv2" |
| 15 | LIC_FILES_CHKSUM = "file://COPYING.tomoyo;md5=751419260aa954499f7abaabaa882bbe" |
| 16 | |
| 17 | FILES_${PN} += "${libdir}/tomoyo" |
| 18 | FILES_${PN}-dbg += "${libdir}/tomoyo/.debug" |
| 19 | |
| 20 | DEPENDS = "linux-libc-headers ncurses" |
| 21 | |
| 22 | EXTRA_OEMAKE = "-e USRLIBDIR=${libdir}" |
| 23 | |
| 24 | do_compile () { |
| 25 | oe_runmake 'CC=${CC}' |
| 26 | } |
| 27 | |
| 28 | do_install() { |
| 29 | oe_runmake install INSTALLDIR=${D} |
| 30 | } |