Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "Test::Warn - Perl extension to test methods for warnings" |
| 2 | DESCRIPTION = "This module provides a few convenience methods for testing \ |
| 3 | warning based code. \ |
| 4 | \ |
| 5 | If you are not already familiar with the Test::More manpage now would be \ |
| 6 | the time to go take a look. \ |
| 7 | " |
| 8 | |
| 9 | SECTION = "libs" |
| 10 | HOMEPAGE= "https://metacpan.org/release/Test-Warn" |
| 11 | |
| 12 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 13 | LIC_FILES_CHKSUM = "file://README;beginline=73;endline=78;md5=42b423d91c92ba59c215835a2ee9b57a" |
| 14 | |
| 15 | CPAN_PACKAGE = "Test-Warn" |
| 16 | CPAN_AUTHOR = "BIGJ" |
| 17 | |
| 18 | SRC_URI = "${CPAN_MIRROR}/authors/id/B/BI/${CPAN_AUTHOR}/${CPAN_PACKAGE}-${PV}.tar.gz" |
| 19 | |
| 20 | SRC_URI[md5sum] = "3d958f43d36db263994affde5da09b51" |
| 21 | SRC_URI[sha256sum] = "ecbca346d379cef8d3c0e4ac0c8eb3b2613d737ffaaeae52271c38d7bf3c6cda" |
| 22 | |
| 23 | S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}" |
| 24 | |
| 25 | inherit cpan ptest-perl |
| 26 | |
| 27 | do_install_ptest() { |
| 28 | cp -r ${B}/blib ${D}${PTEST_PATH} |
| 29 | chown -R root:root ${D}${PTEST_PATH} |
| 30 | } |
| 31 | |
| 32 | RDEPENDS_${PN} += " \ |
| 33 | libsub-uplevel-perl \ |
| 34 | perl-module-blib \ |
| 35 | perl-module-carp \ |
| 36 | perl-module-test-builder \ |
| 37 | perl-module-test-builder-tester \ |
| 38 | perl-module-test-tester \ |
| 39 | " |
| 40 | |
| 41 | RDEPENDS_${PN}-ptest += " \ |
| 42 | perl-module-file-spec \ |
| 43 | perl-module-test-more \ |
| 44 | " |
| 45 | |
| 46 | BBCLASSEXTEND = "native nativesdk" |