Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Miscellaneous utilities specific to Debian" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "Provides a number of small utilities which are used \ |
| 3 | primarily by the installation scripts of Debian packages, although \ |
| 4 | you may use them directly. " |
| 5 | HOMEPAGE = "https://packages.debian.org/sid/debianutils" |
| 6 | BUGTRACKER = "https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=debianutils;dist=unstable" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | SECTION = "base" |
| 8 | LICENSE = "GPLv2 & SMAIL_GPL" |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=9b912cd0cc654134c0ef3424a0705b94" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | |
Andrew Geissler | c3d88e4 | 2020-10-02 09:45:00 -0500 | [diff] [blame] | 11 | SRC_URI = "http://snapshot.debian.org/archive/debian/20200929T025235Z/pool/main/d/${BPN}/${BPN}_${PV}.tar.xz" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | # the package is taken from snapshots.debian.org; that source is static and goes stale |
| 13 | # so we check the latest upstream from a directory that does get updated |
| 14 | UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/" |
| 15 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "3b680e81709b740387335fac8f8806d71611dcf60874e1a792e862e48a1650de" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | |
| 18 | inherit autotools update-alternatives |
| 19 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 20 | S = "${WORKDIR}/debianutils" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 21 | do_configure_prepend() { |
| 22 | sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am |
| 23 | } |
| 24 | |
| 25 | do_install_append() { |
| 26 | if [ "${base_bindir}" != "${bindir}" ]; then |
| 27 | # Debian places some utils into ${base_bindir} as does busybox |
| 28 | install -d ${D}${base_bindir} |
| 29 | for app in run-parts tempfile; do |
| 30 | mv ${D}${bindir}/$app ${D}${base_bindir}/$app |
| 31 | done |
| 32 | fi |
| 33 | } |
| 34 | |
| 35 | # Note that we package the update-alternatives name. |
| 36 | # |
| 37 | PACKAGES =+ "${PN}-run-parts" |
| 38 | FILES_${PN}-run-parts = "${base_bindir}/run-parts.debianutils" |
| 39 | |
| 40 | RDEPENDS_${PN} += "${PN}-run-parts" |
| 41 | RDEPENDS_${PN}_class-native = "" |
| 42 | |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 43 | ALTERNATIVE_PRIORITY = "30" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 44 | ALTERNATIVE_${PN} = "add-shell installkernel remove-shell savelog tempfile which" |
| 45 | |
| 46 | ALTERNATIVE_PRIORITY_${PN}-run-parts = "60" |
| 47 | ALTERNATIVE_${PN}-run-parts = "run-parts" |
| 48 | |
| 49 | ALTERNATIVE_${PN}-doc = "which.1" |
| 50 | ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1" |
| 51 | |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 52 | ALTERNATIVE_LINK_NAME[add-shell] = "${sbindir}/add-shell" |
| 53 | ALTERNATIVE_LINK_NAME[installkernel] = "${sbindir}/installkernel" |
| 54 | ALTERNATIVE_LINK_NAME[remove-shell] = "${sbindir}/remove-shell" |
| 55 | ALTERNATIVE_LINK_NAME[run-parts] = "${base_bindir}/run-parts" |
| 56 | ALTERNATIVE_LINK_NAME[savelog] = "${bindir}/savelog" |
| 57 | ALTERNATIVE_LINK_NAME[tempfile] = "${base_bindir}/tempfile" |
| 58 | ALTERNATIVE_LINK_NAME[which] = "${bindir}/which" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 59 | |
| 60 | BBCLASSEXTEND = "native" |