Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | DESCRIPTION = "gvfs is a userspace virtual filesystem" |
| 2 | LICENSE = "LGPL-2.0-only" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=05df38dd77c35ec8431f212410a3329e" |
| 4 | |
| 5 | GNOMEBASEBUILDCLASS = "meson" |
| 6 | inherit gnomebase gsettings bash-completion gettext upstream-version-is-even features_check useradd |
| 7 | |
| 8 | DEPENDS += "libsecret glib-2.0 glib-2.0-native libgudev shadow-native \ |
| 9 | gsettings-desktop-schemas dbus" |
| 10 | |
| 11 | RDEPENDS:${PN} += "gsettings-desktop-schemas" |
| 12 | |
| 13 | SRC_URI = "https://download.gnome.org/sources/${BPN}/${@gnome_verdir("${PV}")}/${BPN}-${PV}.tar.xz;name=archive" |
| 14 | |
| 15 | SRC_URI[archive.sha256sum] = "cbc2f564d2e9f00c760673f42d6803bce3e081ab7ffb4456deffffba9339b4dd" |
| 16 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame^] | 17 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 18 | |
| 19 | EXTRA_OEMESON = " \ |
| 20 | -Dbluray=false \ |
| 21 | -Dgoa=false \ |
| 22 | -Dgoogle=false \ |
| 23 | -Dnfs=false \ |
| 24 | " |
| 25 | |
| 26 | PACKAGES =+ "gvfsd-ftp gvfsd-sftp gvfsd-trash" |
| 27 | |
| 28 | FILES:${PN} += " \ |
| 29 | ${datadir}/glib-2.0 \ |
| 30 | ${datadir}/GConf \ |
| 31 | ${datadir}/dbus-1/services \ |
| 32 | ${libdir}/gio/modules/*.so \ |
| 33 | ${libdir}/tmpfiles.d \ |
| 34 | ${systemd_user_unitdir} \ |
| 35 | " |
| 36 | |
| 37 | FILES:${PN}-dbg += "${libdir}/gio/modules/.debug/*" |
| 38 | FILES:${PN}-dev += "${libdir}/gio/modules/*.la" |
| 39 | |
| 40 | FILES:gvfsd-ftp = "${libexecdir}/gvfsd-ftp ${datadir}/gvfs/mounts/ftp.mount" |
| 41 | FILES:gvfsd-sftp = "${libexecdir}/gvfsd-sftp ${datadir}/gvfs/mounts/sftp.mount" |
| 42 | FILES:gvfsd-trash = "${libexecdir}/gvfsd-trash ${datadir}/gvfs/mounts/trash.mount" |
| 43 | |
| 44 | RRECOMMENDS:gvfsd-ftp += "openssh-sftp openssh-ssh" |
| 45 | |
| 46 | PACKAGECONFIG ?= "libgphoto2 \ |
| 47 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 48 | ${@bb.utils.contains('DISTRO_FEATURES','polkit','udisks2','',d)} \ |
| 49 | ${@bb.utils.contains('DISTRO_FEATURES','polkit','admin','',d)} \ |
| 50 | " |
| 51 | |
| 52 | PACKAGECONFIG[udisks2] = "-Dudisks2=true, -Dudisks2=false, udisks2, udisks2" |
| 53 | PACKAGECONFIG[admin] = "-Dadmin=true, -Dadmin=false, libcap polkit" |
| 54 | PACKAGECONFIG[afc] = "-Dafc=true, -Dafc=false, libimobiledevice libplist" |
| 55 | PACKAGECONFIG[archive] = "-Darchive=true, -Darchive=false, libarchive" |
| 56 | PACKAGECONFIG[dnssd] = "-Ddnssd=true, -Ddnssd=false, avahi" |
| 57 | PACKAGECONFIG[gcr] = "-Dgcr=true, -Dgcr=false, gcr" |
| 58 | PACKAGECONFIG[http] = "-Dhttp=true, -Dhttp=false, libsoup-2.4" |
| 59 | PACKAGECONFIG[libmtp] = "-Dmtp=true, -Dmtp=false, libmtp" |
| 60 | PACKAGECONFIG[logind] = "-Dlogind=true, -Dlogind=false, systemd" |
| 61 | PACKAGECONFIG[libgphoto2] = "-Dgphoto2=true, -Dgphoto2=false, libgphoto2" |
| 62 | PACKAGECONFIG[samba] = "-Dsmb=true, -Dsmb=false, samba" |
| 63 | PACKAGECONFIG[systemd] = "-Dsystemduserunitdir=${systemd_user_unitdir} -Dtmpfilesdir=${libdir}/tmpfiles.d, -Dsystemduserunitdir=no -Dtmpfilesdir=no, systemd" |
| 64 | |
| 65 | # needs meta-filesystems |
| 66 | PACKAGECONFIG[fuse] = "-Dfuse=true, -Dfuse=false, fuse3" |
| 67 | |
| 68 | # libcdio-paranoia recipe doesn't exist yet |
| 69 | PACKAGECONFIG[cdda] = "-Dcdda=true, -Dcdda=false, libcdio-paranoia" |
| 70 | |
| 71 | USERADD_PACKAGES = "${PN}" |
| 72 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/${BPN}-1 polkitd" |
| 73 | |
| 74 | do_install:append() { |
| 75 | if ${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'true', 'false', d)}; then |
| 76 | # Fix up permissions on polkit rules.d to work with rpm4 constraints |
| 77 | chmod 700 ${D}/${datadir}/polkit-1/rules.d |
| 78 | chown polkitd:root ${D}/${datadir}/polkit-1/rules.d |
| 79 | fi |
| 80 | |
| 81 | # After rebuilds (not from scracth) it can happen that the executables in |
| 82 | # libexec ar missing executable permission flag. Not sure but it came up |
| 83 | # during transition to meson. Looked into build files and logs but could |
| 84 | # not find suspicious |
| 85 | for exe in `find ${D}/${libexecdir}`; do |
| 86 | chmod +x $exe |
| 87 | done |
| 88 | } |