Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "The squish library (abbreviated to libsquish) is an open source DXT compression library written in C++ " |
| 2 | |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://alpha.cpp;beginline=3;endline=22;md5=6665e479f71feb92d590ea9ae9b9f6d5" |
| 5 | |
| 6 | PV = "1.10+git${SRCPV}" |
| 7 | |
| 8 | SRCREV = "52e7d93c5947f72380521116c05d97c528863ba8" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 9 | SRC_URI = "git://github.com/OpenELEC/libsquish.git;protocol=https;branch=master \ |
| 10 | file://0001-Add-support-for-variable-libdir.patch \ |
| 11 | " |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 15 | EXTRA_OEMAKE = "INSTALL_DIR=${D}${prefix} LIBDIR_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \ |
| 16 | ${@bb.utils.contains('TUNE_FEATURES', 'altivec', 'USE_ALTIVEC=1', '', d)}" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 17 | |
| 18 | do_install() { |
| 19 | install -d ${D}${includedir} |
| 20 | install -d ${D}${libdir}/pkgconfig |
| 21 | oe_runmake install |
| 22 | } |