Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame^] | 1 | SUMMARY = "The extensible, standards compliant build backend used by Hatch" |
| 2 | HOMEPAGE = "https://hatch.pypa.io/latest/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cbe2fd33fc9297692812fc94b7d27fd9" |
| 5 | |
| 6 | inherit pypi python_hatchling |
| 7 | |
| 8 | DEPENDS += "python3-pluggy-native python3-tomli-native python3-pathspec-native python3-packaging-native python3-editables-native" |
| 9 | DEPENDS:remove:class-native = "python3-hatchling-native" |
| 10 | |
| 11 | SRC_URI[sha256sum] = "1401d45d3dd6a5910f64d539acaa943486d5e8b7dda1a97f2b0040fdddc5b85e" |
| 12 | |
| 13 | # Until we have a proper tool to invoke PEP517 builds, hatchling can't |
| 14 | # bootstrap itself automatically. |
| 15 | PEP517_BUILD_API = "hatchling.ouroboros" |
| 16 | |
| 17 | do_compile:prepend() { |
| 18 | export PYTHONPATH=src |
| 19 | } |
| 20 | |
| 21 | BBCLASSEXTEND = "native nativesdk" |