Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Linux Test Project" |
| 2 | DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features." |
| 3 | HOMEPAGE = "https://linux-test-project.github.io/" |
| 4 | SECTION = "console/utils" |
| 5 | LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later & BSD-2-Clause" |
| 6 | LIC_FILES_CHKSUM = "\ |
| 7 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 8 | file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \ |
| 9 | file://testcases/network/can/filter-tests/COPYING;md5=5b155ea7d7f86eae8e8832955d8b70bc \ |
| 10 | " |
| 11 | |
| 12 | DEPENDS = "attr libaio libcap acl openssl zip-native" |
| 13 | DEPENDS:append:libc-musl = " fts " |
| 14 | EXTRA_OEMAKE:append:libc-musl = " LIBC=musl " |
| 15 | EXTRA_OECONF:append:libc-musl = " LIBS=-lfts " |
| 16 | |
| 17 | # since ltp contains x86-64 assembler which uses the frame-pointer register, |
| 18 | # set -fomit-frame-pointer x86-64 to handle cases where optimisation |
| 19 | # is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer |
| 20 | # earlier in CFLAGS, etc. |
| 21 | CFLAGS:append:x86-64 = " -fomit-frame-pointer" |
| 22 | |
| 23 | CFLAGS:append:powerpc64 = " -D__SANE_USERSPACE_TYPES__" |
| 24 | CFLAGS:append:mipsarchn64 = " -D__SANE_USERSPACE_TYPES__" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame^] | 25 | SRCREV = "6f88e0f6f1d6eb12c48c902f50f47ecbd3b0f18a" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 26 | |
| 27 | SRC_URI = "git://github.com/linux-test-project/ltp.git;branch=master;protocol=https \ |
| 28 | file://0001-Remove-OOM-tests-from-runtest-mm.patch \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 29 | file://disable_hanging_tests.patch \ |
| 30 | " |
| 31 | |
| 32 | S = "${WORKDIR}/git" |
| 33 | |
| 34 | inherit autotools-brokensep pkgconfig |
| 35 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame^] | 36 | # Version 20220527 added KVM test infrastructure which currently fails to build with gold due to |
| 37 | # SORT_NONE in linker script which isn't supported by gold: |
| 38 | # https://sourceware.org/bugzilla/show_bug.cgi?id=18097 |
| 39 | # https://github.com/linux-test-project/ltp/commit/3fce2064b54843218d085aae326c8f7ecf3a8c41#diff-39268f0855c634ca48c8993fcd2c95b12a65b79e8d9fa5ccd6b0f5a8785c0dd6R36 |
| 40 | LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd', '', d)}" |
| 41 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 42 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 43 | |
| 44 | export prefix = "/opt/${PN}" |
| 45 | export exec_prefix = "/opt/${PN}" |
| 46 | |
| 47 | PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl," |
| 48 | EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4" |
| 49 | EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite " |
| 50 | # ltp network/rpc test cases ftbfs when libtirpc is found |
| 51 | EXTRA_OECONF += " --without-tirpc " |
| 52 | |
| 53 | do_compile() { |
| 54 | oe_runmake HOSTCC="${CC_FOR_BUILD}" HOST_CFLAGS="${CFLAGS_FOR_BUILD}" HOST_LDFLAGS="${LDFLAGS_FOR_BUILD}" |
| 55 | } |
| 56 | |
| 57 | do_install(){ |
| 58 | install -d ${D}${prefix}/ |
| 59 | oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install include-install |
| 60 | |
| 61 | # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run |
| 62 | # as it lacks dependency on some perl moudle such as LWP::Simple |
| 63 | # And this script previously works as a tool for analyzing failures from LTP |
| 64 | # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses |
| 65 | # http://khack.osdl.org to retrieve ltp test results run on |
| 66 | # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible |
| 67 | rm -rf ${D}${prefix}/bin/STPfailure_report.pl |
| 68 | |
| 69 | # Copy POSIX test suite into ${D}${prefix}/testcases by manual |
| 70 | cp -r testcases/open_posix_testsuite ${D}${prefix}/testcases |
| 71 | |
| 72 | # Makefile were configured in the build system |
| 73 | find ${D}${prefix} -name Makefile | xargs -n 1 sed -i \ |
| 74 | -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \ |
| 75 | -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \ |
| 76 | -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \ |
| 77 | -e 's@[^ ]*--sysroot=[^ "]*@@g' |
| 78 | |
| 79 | # The controllers memcg_stree test seems to cause us hangs and takes 900s |
| 80 | # (maybe we expect more regular output?), anyhow, skip it |
| 81 | sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers |
| 82 | } |
| 83 | |
| 84 | RDEPENDS:${PN} = "\ |
| 85 | attr \ |
| 86 | bash \ |
| 87 | bc \ |
| 88 | coreutils \ |
| 89 | cpio \ |
| 90 | cronie \ |
| 91 | curl \ |
| 92 | e2fsprogs \ |
| 93 | e2fsprogs-mke2fs \ |
| 94 | expect \ |
| 95 | file \ |
| 96 | gawk \ |
| 97 | gdb \ |
| 98 | gzip \ |
| 99 | iproute2 \ |
| 100 | ldd \ |
| 101 | libaio \ |
| 102 | logrotate \ |
| 103 | net-tools \ |
| 104 | perl \ |
| 105 | python3-core \ |
| 106 | procps \ |
| 107 | quota \ |
| 108 | unzip \ |
| 109 | util-linux \ |
| 110 | which \ |
| 111 | tar \ |
| 112 | " |
| 113 | |
| 114 | FILES:${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a" |
| 115 | |
| 116 | # Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail |
| 117 | INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01" |
| 118 | INSANE_SKIP:${PN} += "already-stripped staticdev" |
| 119 | |
| 120 | remove_broken_musl_sources() { |
| 121 | [ "${TCLIBC}" = "musl" ] || return 0 |
| 122 | |
| 123 | cd ${S} |
| 124 | echo "WARNING: remove unsupported tests (until they're fixed)" |
| 125 | |
| 126 | # sync with upstream |
| 127 | # https://github.com/linux-test-project/ltp/blob/master/ci/alpine.sh#L33 |
| 128 | rm -rfv \ |
| 129 | testcases/kernel/syscalls/confstr/confstr01.c \ |
| 130 | testcases/kernel/syscalls/fmtmsg/fmtmsg01.c \ |
| 131 | testcases/kernel/syscalls/getcontext/getcontext01.c \ |
| 132 | testcases/kernel/syscalls/rt_tgsigqueueinfo/rt_tgsigqueueinfo01.c \ |
| 133 | testcases/kernel/syscalls/timer_create/timer_create01.c \ |
| 134 | testcases/kernel/syscalls/timer_create/timer_create03.c \ |
| 135 | utils/benchmark/ebizzy-0.3 |
| 136 | } |
| 137 | do_patch[postfuncs] += "remove_broken_musl_sources" |
| 138 | |
| 139 | # Avoid file dependency scans, as LTP checks for things that may or may not |
| 140 | # exist on the running system. For instance it has specific checks for |
| 141 | # csh and ksh which are not typically part of OpenEmbedded systems (but |
| 142 | # can be added via additional layers.) |
| 143 | SKIP_FILEDEPS:${PN} = '1' |