blob: a15b51e31c60dbe3b6ecc7ee1a68af758e539c17 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
Andrew Geisslerd25ed322020-06-27 00:28:28 -05002HOMEPAGE = "https://pypi.org/project/setuptools"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05003SECTION = "devel/python"
Patrick Williamsc0f7c042017-02-23 20:41:17 -06004LICENSE = "MIT"
Andrew Geisslerd1e89492021-02-12 15:35:20 -06005LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=7a7126e068206290f3fe9f8d6c713ea6"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05006
Andrew Geissler635e0e42020-08-21 15:58:33 -05007inherit pypi setuptools3
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05008
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009SRC_URI_append_class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch"
10
William A. Kennington IIIac69b482021-06-02 12:28:27 -070011SRC_URI += "file://0001-change-shebang-to-python3.patch \
12 file://reproducibility.patch"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
William A. Kennington IIIac69b482021-06-02 12:28:27 -070014SRC_URI[sha256sum] = "401cbf33a7bf817d08014d51560fc003b895c4cdc1a5b521ad2969e928a07535"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050015
Brad Bishop316dfdd2018-06-25 12:45:53 -040016DEPENDS += "${PYTHON_PN}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050017
Brad Bishop316dfdd2018-06-25 12:45:53 -040018RDEPENDS_${PN} = "\
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050019 ${PYTHON_PN}-2to3 \
Brad Bishop316dfdd2018-06-25 12:45:53 -040020 ${PYTHON_PN}-compile \
21 ${PYTHON_PN}-compression \
22 ${PYTHON_PN}-ctypes \
23 ${PYTHON_PN}-distutils \
24 ${PYTHON_PN}-email \
25 ${PYTHON_PN}-html \
Andrew Geisslerc182c622020-05-15 14:13:32 -050026 ${PYTHON_PN}-json \
Brad Bishop316dfdd2018-06-25 12:45:53 -040027 ${PYTHON_PN}-netserver \
28 ${PYTHON_PN}-numbers \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050029 ${PYTHON_PN}-pickle \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060030 ${PYTHON_PN}-pkg-resources \
Brad Bishop316dfdd2018-06-25 12:45:53 -040031 ${PYTHON_PN}-pkgutil \
32 ${PYTHON_PN}-plistlib \
33 ${PYTHON_PN}-shell \
34 ${PYTHON_PN}-stringold \
35 ${PYTHON_PN}-threading \
36 ${PYTHON_PN}-unittest \
37 ${PYTHON_PN}-xml \
38"
Andrew Geissler635e0e42020-08-21 15:58:33 -050039
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050040do_install_prepend() {
Patrick Williamsc0f7c042017-02-23 20:41:17 -060041 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050042}
Brad Bishop316dfdd2018-06-25 12:45:53 -040043
44BBCLASSEXTEND = "native nativesdk"
Brad Bishop15ae2502019-06-18 21:44:24 -040045
46# The pkg-resources module can be used by itself, without the package downloader
47# and easy_install. Ship it in a separate package so that it can be used by
48# minimal distributions.
49PACKAGES =+ "${PYTHON_PN}-pkg-resources "
50FILES_${PYTHON_PN}-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*"
Andrew Geissler5a43b432020-06-13 10:46:56 -050051RDEPENDS_${PYTHON_PN}-pkg-resources = "\
52 ${PYTHON_PN}-compression \
53 ${PYTHON_PN}-email \
54 ${PYTHON_PN}-plistlib \
55 ${PYTHON_PN}-pprint \
56"