Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Full-featured IRC plugin: multi-servers, proxy support, IPv6, SASL authentication, nicklist, DCC, and many other features" |
| 2 | HOMEPAE = "https://weechat.org/" |
| 3 | SECTION = "net" |
| 4 | LICENSE = "GPL-3.0-only" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464" |
| 6 | |
| 7 | DEPENDS = "openssl zlib icu libgcrypt gnutls curl aspell" |
| 8 | |
| 9 | SRC_URI = "https://weechat.org/files/src/weechat-${PV}.tar.xz \ |
| 10 | file://0001-use-pkg-config-for-gcrypt-instead.patch \ |
| 11 | " |
| 12 | |
| 13 | SRC_URI[sha256sum] = "7e088109ad5dfbcb08a9a6b1dd70ea8236093fed8a13ee9d9c98881d7b1aeae7" |
| 14 | |
| 15 | inherit cmake pkgconfig |
| 16 | |
| 17 | PACKAGECONFIG ??= " ncurses python" |
| 18 | PACKAGECONFIG[ncurses] = "-DENABLE_NCURSES=ON,-DENABLE_NCURSES=OFF,ncurses" |
| 19 | PACKAGECONFIG[python] = "-DENABLE_PYTHON=ON,-DENABLE_PYTHON=OFF,python3,python3" |
| 20 | |
| 21 | EXTRA_OECMAKE:append = " -DENABLE_PHP=OFF -DENABLE_TCL=OFF -DENABLE_LUA=OFF \ |
| 22 | -DENABLE_JAVASCRIPT=OFF -DENABLE_RUBY=OFF \ |
| 23 | -DENABLE_GUILE=OFF -DENABLE_PERL=OFF -DENABLE_ASPELL=ON \ |
| 24 | -DLIBDIR=${libdir}" |
| 25 | |
| 26 | do_configure:prepend(){ |
| 27 | # Make sure we get dependencies from recipe-sysroot |
| 28 | sed -i -e 's# /usr/bin# ${RECIPE_SYSROOT}/${bindir}/#g' ${S}/cmake/FindPerl.cmake |
| 29 | sed -i -e 's# /usr/local/bin##g' ${S}/cmake/FindPerl.cmake |
| 30 | sed -i -e 's# /usr/pkg/bin##g' ${S}/cmake/FindPerl.cmake |
| 31 | } |
| 32 | |
| 33 | do_install:append(){ |
| 34 | rm -rf ${D}/${datadir} |
| 35 | } |
| 36 | |