Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Firmware testsuite" |
| 2 | DESCRIPTION = "The tool fwts comprises of over fifty tests that are designed to exercise and test different aspects of a machine's firmware. Many of these tests need super user access to read BIOS data and ACPI tables, so the tool requires running with super user privileges (e.g. with sudo)." |
| 3 | HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts" |
| 4 | |
| 5 | LICENSE = "GPLv2+" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 7 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 8 | PV = "18.05.00+git${SRCPV}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 9 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 10 | SRCREV = "b0ec7aa2ef743d113fd8c5e57c0ca3d5edd86f0e" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 11 | SRC_URI = "git://kernel.ubuntu.com/hwe/fwts.git \ |
| 12 | file://0001-ignore-constant-logical-operand-warning-with-clang.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 13 | file://0001-Include-poll.h-instead-of-deprecated-sys-poll.h.patch \ |
| 14 | file://0002-Define-__SWORD_TYPE-if-not-defined-by-libc.patch \ |
| 15 | file://0003-Undefine-PAGE_SIZE.patch \ |
| 16 | file://0001-Add-correct-printf-qualifier-for-off_t.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 17 | file://0003-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | file://0001-Remove-Werror-from-build.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 19 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 23 | COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 24 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 25 | DEPENDS = "libpcre json-c glib-2.0 dtc bison-native" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 26 | DEPENDS_append_libc-musl = " libexecinfo" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 27 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | inherit autotools bash-completion pkgconfig |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 29 | |
| 30 | CFLAGS += "-I${STAGING_INCDIR}/json-c -Wno-error=unknown-pragmas" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 31 | LDFLAGS_append_libc-musl = " -lexecinfo" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 32 | |
| 33 | FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}" |
| 34 | FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la" |
| 35 | FILES_${PN}-staticdev += "${libdir}/fwts/lib*a" |
| 36 | FILES_${PN}-dbg += "${libdir}/fwts/.debug" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 37 | |
| 38 | TOOLCHAIN = "gcc" |
| 39 | |