Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "LDAP Perl module" |
| 2 | DESCRIPTION = "Net::LDAP is a collection of modules that implements \ |
| 3 | a LDAP services API for Perl programs. The module may be used to \ |
| 4 | search directories or perform maintenance functions such as adding, \ |
| 5 | deleting or modifying entries." |
| 6 | |
| 7 | SECTION = "libs" |
| 8 | |
| 9 | LICENSE = "Artistic-1.0|GPLv1+" |
| 10 | LIC_FILES_CHKSUM = "file://README;beginline=3;endline=5;md5=4d6588c2fa0d38ae162f6314d201d89e" |
| 11 | |
| 12 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MA/MARSCHAP/perl-ldap-${PV}.tar.gz" |
| 13 | |
| 14 | SRC_URI[md5sum] = "d057c8db76913d95c0e460c7bdd98b27" |
| 15 | SRC_URI[sha256sum] = "5f57dd261dc16ebf942a272ddafe69526598df71151a51916edc37a4f2f23834" |
| 16 | |
| 17 | S = "${WORKDIR}/perl-ldap-${PV}" |
| 18 | |
| 19 | inherit cpan |
| 20 | |
| 21 | do_configure_prepend() { |
| 22 | perl -pi -e 's/auto_install_now.*//g' Makefile.PL |
| 23 | } |
| 24 | |
| 25 | RDEPENDS_${PN} = "perl \ |
| 26 | libconvert-asn1-perl \ |
| 27 | libio-socket-ssl-perl \ |
| 28 | libauthen-sasl-perl \ |
| 29 | " |