Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Net::LibIDN - Perl bindings for GNU Libidn" |
| 2 | DESCRIPTION = "\ |
| 3 | Provides bindings for GNU Libidn, a C library for handling Internationalized \ |
| 4 | Domain Names according to IDNA (RFC 3490), in a way very much inspired by \ |
| 5 | Turbo Fredriksson's PHP-IDN. \ |
| 6 | " |
| 7 | SECTION = "libs" |
| 8 | LICENSE = "Artistic-1.0 | GPLv1+" |
| 9 | HOMEPAGE = "http://search.cpan.org/dist/Net-LibIDN/" |
| 10 | DEPENDS += "libidn" |
| 11 | # We must need glibc-gconvs to enable charset related functions, |
| 12 | # such as Net::LibIDN::idn_to_ascii(). |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 13 | RDEPENDS_${PN}_append_libc-glibc = " glibc-gconvs" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 14 | |
| 15 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TH/THOR/Net-LibIDN-${PV}.tar.gz" |
| 16 | SRC_URI[md5sum] = "c3e4de2065009d67bcb1df0afb473e12" |
| 17 | SRC_URI[sha256sum] = "2f8acc9442b3866ec7dc63cd449fc693ae3e930d5d3e5e9430fbb6f393bdbb17" |
| 18 | |
| 19 | SRC_URI += "file://libidn-wr-cross-compile.patch" |
| 20 | |
| 21 | LIC_FILES_CHKSUM = "file://README;beginline=42;endline=92;md5=3374ea0369ca3ead6047520477a43147" |
| 22 | |
| 23 | S = "${WORKDIR}/Net-LibIDN-${PV}" |
| 24 | |
| 25 | EXTRA_CPANFLAGS = "--with-libidn=${STAGING_LIBDIR} --with-libidn-inc=${STAGING_INCDIR} --compiler='${CC}'" |
| 26 | EXTRA_CPANFLAGS += "--disable-tld" |
| 27 | |
| 28 | inherit cpan |
| 29 | |
| 30 | FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/Net/LibIDN/.debug/" |
| 31 | |
| 32 | do_configure_prepend() { |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 33 | rm -rf ${S}/.pc/ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 34 | } |