Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Xelerance version of the Layer 2 Tunneling Protocol (L2TP) daemon" |
| 2 | HOMEPAGE = "http://www.xelerance.com/software/xl2tpd/" |
| 3 | SECTION = "net" |
| 4 | DEPENDS = "ppp virtual/kernel" |
| 5 | |
| 6 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 7 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 8 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 10 | |
| 11 | SRC_URI = "git://github.com/xelerance/xl2tpd.git;branch=master;protocol=https" |
| 12 | SRCREV = "1ef2a025981223c1e16fc833bef226c86ff8c295" |
| 13 | |
| 14 | UPSTREAM_CHECK_URI = "https://github.com/xelerance/xl2tpd/releases" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit update-rc.d |
| 19 | |
| 20 | do_compile () { |
| 21 | oe_runmake CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" PREFIX="${prefix}" KERNELSRC=${STAGING_KERNEL_DIR} all |
| 22 | } |
| 23 | |
| 24 | do_install () { |
| 25 | oe_runmake PREFIX="${D}${prefix}" install |
| 26 | |
| 27 | install -d ${D}${sysconfdir}/init.d |
| 28 | touch ${D}${sysconfdir}/xl2tpd.conf |
| 29 | install -m 0755 debian/xl2tpd.init ${D}${sysconfdir}/init.d/xl2tpd |
| 30 | sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/xl2tpd |
| 31 | sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/xl2tpd |
| 32 | sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/xl2tpd |
| 33 | sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${sysconfdir}/init.d/xl2tpd |
| 34 | |
| 35 | install -d ${D}${sysconfdir}/default |
| 36 | install -m 0644 debian/xl2tpd.default ${D}${sysconfdir}/default/xl2tpd |
| 37 | } |
| 38 | |
| 39 | CONFFILES:${PN} += "${sysconfdir}/xl2tpd.conf ${sysconfdir}/default/xl2tpd" |
| 40 | |
| 41 | INITSCRIPT_PACKAGES = "${PN}" |
| 42 | INITSCRIPT_NAME:${PN} = "xl2tpd" |