Potin Lai | e096c41 | 2022-09-01 14:12:25 +0800 | [diff] [blame] | 1 | LICENSE = "Apache-2.0" |
| 2 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 3 | |
| 4 | inherit obmc-phosphor-systemd |
| 5 | |
| 6 | RDEPENDS:${PN} += " bash motor-ctrl" |
Potin Lai | 83c294d | 2022-10-17 16:24:32 +0800 | [diff] [blame] | 7 | RDEPENDS:${PN} += " mdio-tools" |
Potin Lai | e096c41 | 2022-09-01 14:12:25 +0800 | [diff] [blame] | 8 | |
| 9 | SRC_URI += " \ |
| 10 | file://bletchley-system-state-init \ |
| 11 | file://bletchley-system-state-init@.service \ |
Potin Lai | 291d138 | 2023-01-03 09:31:22 +0800 | [diff] [blame] | 12 | file://bletchley-usbmux-util \ |
Potin Lai | 7bb0c21 | 2023-04-07 16:15:47 +0800 | [diff] [blame^] | 13 | file://bletchley-net-util \ |
Potin Lai | e096c41 | 2022-09-01 14:12:25 +0800 | [diff] [blame] | 14 | " |
| 15 | |
| 16 | do_install() { |
| 17 | install -d ${D}${libexecdir} |
| 18 | install -m 0755 ${WORKDIR}/bletchley-system-state-init ${D}${libexecdir} |
Potin Lai | 291d138 | 2023-01-03 09:31:22 +0800 | [diff] [blame] | 19 | |
| 20 | install -d ${D}${bindir} |
| 21 | install -m 0755 ${WORKDIR}/bletchley-usbmux-util ${D}${bindir} |
Potin Lai | 7bb0c21 | 2023-04-07 16:15:47 +0800 | [diff] [blame^] | 22 | install -m 0755 ${WORKDIR}/bletchley-net-util ${D}${bindir} |
Potin Lai | e096c41 | 2022-09-01 14:12:25 +0800 | [diff] [blame] | 23 | } |
| 24 | |
| 25 | |
| 26 | TGT = "${SYSTEMD_DEFAULT_TARGET}" |
| 27 | BLETCHLEY_SYS_ST_INIT_INSTFMT="../bletchley-system-state-init@.service:${TGT}.wants/bletchley-system-state-init@{0}.service" |
| 28 | |
| 29 | SYSTEMD_SERVICE:${PN} += "bletchley-system-state-init@.service" |
| 30 | SYSTEMD_LINK:${PN} += "${@compose_list(d, 'BLETCHLEY_SYS_ST_INIT_INSTFMT', 'OBMC_HOST_INSTANCES')}" |