Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "LFTP is a sophisticated file transfer program with \ |
| 2 | command line interface. It supports FTP, HTTP, \ |
| 3 | FISH, SFTP, HTTPS and FTPS protocols" |
| 4 | HOMEPAGE = "http://lftp.yar.ru/" |
| 5 | SECTION = "console/network" |
| 6 | LICENSE = "GPLv3" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 8 | |
| 9 | SRC_URI = "http://lftp.yar.ru/ftp/lftp-${PV}.tar.bz2 \ |
| 10 | file://fix-gcc-6-conflicts-signbit.patch \ |
| 11 | " |
| 12 | SRC_URI[md5sum] = "a56b5047dbfda052df4c1dfd197aa092" |
| 13 | SRC_URI[sha256sum] = "a853edbd075b008c315679c7882b6dcc6821ed2365d2ed843a412acd3d40da0e" |
| 14 | |
| 15 | inherit autotools gettext pkgconfig |
| 16 | |
| 17 | acpaths = "-I ./m4" |
| 18 | |
| 19 | EXTRA_OECONF += "--with-modules --disable-rpath" |
| 20 | |
| 21 | PACKAGECONFIG ??= "openssl zlib gnutls readline expat" |
| 22 | PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl" |
| 23 | PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_INCDIR}/.., --without-zlib, zlib" |
| 24 | PACKAGECONFIG[gnutls] = "--with-gnutls, --without-gnutls, gnutls" |
| 25 | PACKAGECONFIG[readline] = "--with-readline=${STAGING_INCDIR}/.. --with-readline-inc=${STAGING_INCDIR} --with-readline-lib=-lreadline, --with-readline=no, readline" |
| 26 | PACKAGECONFIG[expat] = "--with-expat=${STAGING_INCDIR}/.. --with-expat-inc=${STAGING_INCDIR} --with-expat-lib=-lexpat, , expat" |
| 27 | |
| 28 | do_install_append() { |
| 29 | rm -rf ${D}${libdir}/charset.alias |
| 30 | } |
| 31 | FILES_${PN} += "${datadir}/icons/hicolor" |
| 32 | FILES_${PN}-dbg += "${libdir}/lftp/${PV}/.debug" |
| 33 | RDEPENDS_${PN} = "perl bash readline" |