Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "kexecboot linux-as-bootloader" |
| 2 | DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec." |
| 3 | HOMEPAGE = "http://kexecboot.org" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 6 | PV = "0.6+git${SRCPV}" |
| 7 | S = "${WORKDIR}/git" |
| 8 | SRC_URI = "git://github.com/kexecboot/kexecboot.git" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 9 | SRCREV = "4c01d6960aa6a9d03675605062469ab777fa2b01" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | inherit autotools |
| 11 | |
| 12 | EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250" |
| 13 | |
| 14 | do_install () { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | install -D -m 0755 ${B}/src/kexecboot ${D}${bindir}/kexecboot |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 16 | install -d ${D}/proc |
| 17 | install -d ${D}/mnt |
| 18 | install -d ${D}/dev |
| 19 | install -d ${D}/sys |
| 20 | } |
| 21 | |
| 22 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 23 | |
| 24 | FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys" |
| 25 | |
| 26 | pkg_postinst_${PN} () { |
| 27 | ln -sf ${bindir}/kexecboot $D/init |
| 28 | } |
| 29 | |
| 30 | BBCLASSEXTEND = "klibc" |