Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 1 | SUMMARY = "Light-weight C++ XML Processing Library" |
| 2 | DESCRIPTION = "pugixml is a C++ XML processing library, which consists of a \ |
| 3 | DOM-like interface with rich traversal/modification capabilities, \ |
| 4 | an extremely fast XML parser which constructs the DOM tree from \ |
| 5 | n XML file/buffer, and an XPath 1.0 implementation for complex \ |
| 6 | data-driven tree queries." |
Andrew Geissler | eafcbb8 | 2020-06-05 17:59:17 -0500 | [diff] [blame] | 7 | HOMEPAGE = "https://pugixml.org/" |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 8 | |
| 9 | LICENSE = "MIT" |
Brad Bishop | 87b3cb8 | 2019-11-15 16:35:37 -0500 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://readme.txt;beginline=29;endline=52;md5=d5ee91fb74cbb64223b3693fd64eb169" |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 11 | |
| 12 | SRC_URI = "https://github.com/zeux/${BPN}/releases/download/v${PV}/${BP}.tar.gz" |
Brad Bishop | 87b3cb8 | 2019-11-15 16:35:37 -0500 | [diff] [blame] | 13 | SRC_URI[md5sum] = "f97237e9908201c6d8536210747b66af" |
| 14 | SRC_URI[sha256sum] = "55f399fbb470942410d348584dc953bcaec926415d3462f471ef350f29b5870a" |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 15 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | UPSTREAM_CHECK_URI = "https://github.com/zeux/${BPN}/releases" |
| 17 | |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 18 | inherit cmake |
| 19 | |
Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 20 | EXTRA_OECMAKE += "-DBUILD_PKGCONFIG=ON \ |
| 21 | -DBUILD_SHARED_LIBS=ON \ |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 22 | -DCMAKE_BUILD_TYPE=Release \ |
| 23 | " |
Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 24 | |
| 25 | BBCLASSEXTEND = "native nativesdk" |