Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "LXDM is the lightweight display manager" |
| 2 | HOMEPAGE = "http://blog.lxde.org/?p=531" |
| 3 | LICENSE = "GPLv3" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 5 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}%20${PV}/${BPN}-${PV}.tar.xz \ |
| 6 | file://lxdm.conf \ |
| 7 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'file://lxdm-pam file://lxdm-pam-debug', '', d)} \ |
| 8 | ${@bb.utils.contains("DISTRO_TYPE", "debug", "", "file://0001-lxdm.conf.in-blacklist-root-for-release-images.patch",d)} \ |
| 9 | file://0002-let-autotools-create-lxdm.conf.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 10 | file://0003-check-for-libexecinfo-providing-backtrace-APIs.patch \ |
| 11 | file://0004-fix-css-under-gtk-3.20.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 13 | SRC_URI[md5sum] = "061caae432634e6db38bbdc84bc6ffa0" |
| 14 | SRC_URI[sha256sum] = "4891efee81c72a400cc6703e40aa76f3f3853833d048b72ec805da0f93567f2f" |
| 15 | |
| 16 | PE = "1" |
| 17 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | DEPENDS = "virtual/libintl intltool-native cairo dbus gdk-pixbuf glib-2.0 gtk+3 virtual/libx11 libxcb pango iso-codes" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 19 | DEPENDS += "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "consolekit", d)}" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 20 | DEPENDS_append_libc-musl = " libexecinfo" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 21 | |
| 22 | # combine oe-core way with angstrom DISTRO_TYPE |
| 23 | DISTRO_TYPE ?= "${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}" |
| 24 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 25 | inherit autotools pkgconfig gettext systemd features_check |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 26 | # depends on virtual/libx11 |
| 27 | REQUIRED_DISTRO_FEATURES = "x11" |
| 28 | |
| 29 | CFLAGS_append = " -fno-builtin-fork -fno-builtin-memset -fno-builtin-strstr " |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 30 | LDFLAGS_append_libc-musl = " -lexecinfo" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 31 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 32 | EXTRA_OECONF += "--enable-gtk3=yes --enable-password=yes --with-x -with-xconn=xcb \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 33 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/ --disable-consolekit', '--without-systemdsystemunitdir', d)} \ |
| 34 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} \ |
| 35 | " |
| 36 | |
| 37 | do_configure_prepend() { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 38 | cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po/ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 39 | } |
| 40 | |
| 41 | do_compile_append() { |
| 42 | # default background configured not available / no password field available / no default screensaver |
| 43 | sed -i -e 's,bg=,# bg=,g' \ |
| 44 | -e 's,# skip_password=,skip_password=,g' \ |
| 45 | -e 's,# arg=.*,arg=${bindir}/X -s 0,g' \ |
| 46 | ${S}/data/lxdm.conf.in |
| 47 | # add default configuration |
| 48 | oe_runmake -C ${B}/data lxdm.conf |
| 49 | } |
| 50 | |
| 51 | do_install_append() { |
| 52 | install -d ${D}${localstatedir}/lib/lxdm |
| 53 | install -m 644 ${WORKDIR}/lxdm.conf ${D}${localstatedir}/lib/lxdm |
| 54 | if ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'true', 'false', d)}; then |
| 55 | # ArchLinux version of pam config has the following advantages: |
| 56 | # * simple setup of passwordless login |
| 57 | # * in XFCE powerdown/restart enabled in logoff dialog |
| 58 | install -m 644 ${WORKDIR}/${@bb.utils.contains("DISTRO_TYPE", "debug", "lxdm-pam-debug", "lxdm-pam",d)} ${D}${sysconfdir}/pam.d/lxdm |
| 59 | fi |
| 60 | } |
| 61 | |
| 62 | # make installed languages choosable |
| 63 | pkg_postinst_${PN} () { |
| 64 | langs="" |
| 65 | for lang in `find $D${libdir}/locale -maxdepth 1 | grep _ | sort`; do |
| 66 | lang=`basename $lang` |
| 67 | if [ "x$langs" = "x" ]; then |
| 68 | langs="$lang" |
| 69 | else |
| 70 | langs="$langs $lang" |
| 71 | fi |
| 72 | done |
| 73 | sed -i "s:last_langs=.*$:last_langs=$langs:g" $D${localstatedir}/lib/lxdm/lxdm.conf |
| 74 | } |
| 75 | |
| 76 | RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-loginuid', '', d)} setxkbmap bash librsvg-gtk" |
| 77 | |
| 78 | RPROVIDES_${PN} += "${PN}-systemd" |
| 79 | RREPLACES_${PN} += "${PN}-systemd" |
| 80 | RCONFLICTS_${PN} += "${PN}-systemd" |
| 81 | SYSTEMD_SERVICE_${PN} = "lxdm.service" |