blob: 8e8388e8d493cd81861f0256d09cb0d8fc5d2bc5 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The SPIR-V Tools project provides an API and commands for \
2processing SPIR-V modules"
3DESCRIPTION = "The project includes an assembler, binary module parser, \
4disassembler, validator, and optimizer for SPIR-V."
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7SECTION = "graphics"
8
9S = "${WORKDIR}/git"
10DEST_DIR = "${S}/external"
11SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git;name=spirv-tools \
Brad Bishop19323692019-04-05 15:28:33 -040012 git://github.com/KhronosGroup/SPIRV-Headers.git;name=spirv-headers;destsuffix=${DEST_DIR}/spirv-headers \
13 git://github.com/google/effcee.git;name=effcee;destsuffix=${DEST_DIR}/effcee \
14 git://github.com/google/re2.git;name=re2;destsuffix=${DEST_DIR}/re2 \
15 git://github.com/google/googletest.git;name=googletest;destsuffix=${DEST_DIR}/googletest \
Brad Bishope42b3e32020-01-15 22:08:42 -050016 file://0001-Respect-CMAKE_INSTALL_LIBDIR-in-installed-CMake-file.patch \
17 file://0001-Avoid-pessimizing-std-move-3124.patch \
Brad Bishop19323692019-04-05 15:28:33 -040018"
Brad Bishope42b3e32020-01-15 22:08:42 -050019SRCREV_spirv-tools = "c413b982c316b14e784f50d941814fc737b55b4a"
20SRCREV_spirv-headers = "af64a9e826bf5bb5fcd2434dd71be1e41e922563"
21SRCREV_effcee = "cd25ec17e9382f99a895b9ef53ff3c277464d07d"
22SRCREV_re2 = "5bd613749fd530b576b890283bfb6bc6ea6246cb"
23SRCREV_googletest = "f2fb48c3b3d79a75a88a99fba6576b25d42ec528"
Brad Bishop19323692019-04-05 15:28:33 -040024
25inherit cmake python3native
26
Brad Bishope42b3e32020-01-15 22:08:42 -050027EXTRA_OECMAKE += "-DSPIRV_WERROR=OFF"
28
Brad Bishop19323692019-04-05 15:28:33 -040029do_install_append() {
30 install -d ${D}/${includedir}/spirv
31 install -m 0644 ${DEST_DIR}/spirv-headers/include/spirv/1.2/* ${D}/${includedir}/spirv
32}
33
34FILES_SOLIBSDEV = ""
35FILES_${PN} += "${libdir}/*.so"