Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "The SPIR-V Tools project provides an API and commands for \ |
| 2 | processing SPIR-V modules" |
| 3 | DESCRIPTION = "The project includes an assembler, binary module parser, \ |
| 4 | disassembler, validator, and optimizer for SPIR-V." |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 7 | SECTION = "graphics" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | DEST_DIR = "${S}/external" |
| 11 | SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git;name=spirv-tools \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | git://github.com/KhronosGroup/SPIRV-Headers.git;name=spirv-headers;destsuffix=${DEST_DIR}/spirv-headers \ |
| 13 | git://github.com/google/effcee.git;name=effcee;destsuffix=${DEST_DIR}/effcee \ |
| 14 | git://github.com/google/re2.git;name=re2;destsuffix=${DEST_DIR}/re2 \ |
| 15 | git://github.com/google/googletest.git;name=googletest;destsuffix=${DEST_DIR}/googletest \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 16 | file://0001-Respect-CMAKE_INSTALL_LIBDIR-in-installed-CMake-file.patch \ |
| 17 | file://0001-Avoid-pessimizing-std-move-3124.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | " |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 19 | SRCREV_spirv-tools = "c413b982c316b14e784f50d941814fc737b55b4a" |
| 20 | SRCREV_spirv-headers = "af64a9e826bf5bb5fcd2434dd71be1e41e922563" |
| 21 | SRCREV_effcee = "cd25ec17e9382f99a895b9ef53ff3c277464d07d" |
| 22 | SRCREV_re2 = "5bd613749fd530b576b890283bfb6bc6ea6246cb" |
| 23 | SRCREV_googletest = "f2fb48c3b3d79a75a88a99fba6576b25d42ec528" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | |
| 25 | inherit cmake python3native |
| 26 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 27 | EXTRA_OECMAKE += "-DSPIRV_WERROR=OFF" |
| 28 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 29 | do_install_append() { |
| 30 | install -d ${D}/${includedir}/spirv |
| 31 | install -m 0644 ${DEST_DIR}/spirv-headers/include/spirv/1.2/* ${D}/${includedir}/spirv |
| 32 | } |
| 33 | |
| 34 | FILES_SOLIBSDEV = "" |
| 35 | FILES_${PN} += "${libdir}/*.so" |