blob: 5d3508857205c5053d88b2627ff783c242f2c873 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "An abstraction layer for touchscreen panel events"
2DESCRIPTION = "Tslib is an abstraction layer for touchscreen panel \
3events, as well as a filter stack for the manipulation of those events. \
4Tslib is generally used on embedded devices to provide a common user \
5space interface to touchscreen functionality."
6HOMEPAGE = "http://tslib.org/"
7
8AUTHOR = "Martin Kepplinger <martink@posteo.de>"
9SECTION = "base"
10LICENSE = "LGPLv2+ & GPLv2+"
11LIC_FILES_CHKSUM = "\
12 file://COPYING;md5=fc178bcd425090939a8b634d1d6a9594 \
13 file://tests/COPYING;md5=a23a74b3f4caf9616230789d94217acb \
14"
15
16SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \
17 file://ts.conf \
18 file://tslib.sh \
Andrew Geisslerd221e032020-07-10 16:13:21 -050019 "
20SRC_URI[sha256sum] = "aaf0aed410a268d7b51385d07fe4d9d64312038e87c447ec8a24c8db0a15617a"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021
22UPSTREAM_CHECK_URI = "https://github.com/kergoth/tslib/releases"
23
24inherit autotools pkgconfig
25
26PACKAGECONFIG ??= "debounce dejitter iir linear median pthres skip lowpass invert variance input touchkit waveshare"
27PACKAGECONFIG[debounce] = "--enable-debounce,--disable-debounce"
28PACKAGECONFIG[dejitter] = "--enable-dejitter,--disable-dejitter"
29PACKAGECONFIG[iir] = "--enable-iir,--disable-iir"
30PACKAGECONFIG[linear] = "--enable-linear,--disable-linear"
31PACKAGECONFIG[median] = "--enable-median,--disable-median"
32PACKAGECONFIG[pthres] = "--enable-pthres,--disable-pthres"
33PACKAGECONFIG[skip] = "--enable-skip,--disable-skip"
34PACKAGECONFIG[lowpass] = "--enable-lowpass,--disable-lowpass"
35PACKAGECONFIG[invert] = "--enable-invert,--disable-invert"
36PACKAGECONFIG[variance] = "--enable-variance,--disable-variance"
37PACKAGECONFIG[input] = "--enable-input,--disable-input"
38PACKAGECONFIG[tatung] = "--enable-tatung,--disable-tatung"
39PACKAGECONFIG[touchkit] = "--enable-touchkit,--disable-touchkit"
40PACKAGECONFIG[waveshare] = "--enable-waveshare,--disable-waveshare"
41PACKAGECONFIG[ucb1x00] = "--enable-ucb1x00,--disable-ucb1x00"
42PACKAGECONFIG[mk712] = "--enable-mk712,--disable-mk712"
43PACKAGECONFIG[h3600] = "--enable-h3600,--disable-h3600"
44PACKAGECONFIG[dmc] = "--enable-dmc,--disable-dmc"
45PACKAGECONFIG[linear-h2200] = "--enable-linear-h2200,--disable-linear-h2200"
46PACKAGECONFIG[corgi] = "--enable-corgi,--disable-corgi"
47PACKAGECONFIG[collie] = "--enable-collie,--disable-collie"
48PACKAGECONFIG[arctic2] = "--enable-arctic2,--disable-arctic2"
49PACKAGECONFIG[dmc_dus3000] = "--enable-dmc_dus3000,--disable-dmc_dus3000"
50PACKAGECONFIG[cy8mrln-palmpre] = "--enable-cy8mrln-palmpre,--disable-cy8mrln-palmpre"
51PACKAGECONFIG[galax] = "--enable-galax,--disable-galax"
52PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
53
54do_install_prepend() {
55 install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
56}
57
58do_install_append() {
59 install -d ${D}${sysconfdir}/profile.d/
60 install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
61}
62
63RPROVIDES_tslib-conf = "libts-0.0-conf"
64
65PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate tslib-uinput"
66DEBIAN_NOAUTONAME_tslib-conf = "1"
67DEBIAN_NOAUTONAME_tslib-tests = "1"
68DEBIAN_NOAUTONAME_tslib-calibrate = "1"
69DEBIAN_NOAUTONAME_tslib-uinput = "1"
70
71RDEPENDS_${PN} = "tslib-conf"
72RRECOMMENDS_${PN} = "pointercal"
73
74FILES_${PN}-dev += "${libdir}/ts/*.la"
75FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
76FILES_${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*"
77FILES_tslib-calibrate += "${bindir}/ts_calibrate"
78FILES_tslib-uinput += "${bindir}/ts_uinput"
79
80FILES_tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_print_mt \
Brad Bishop2f973922019-11-11 07:58:48 -050081 ${bindir}/ts_test ${bindir}/ts_test_mt ${bindir}/ts_verify ${bindir}/ts_finddev ${bindir}/ts_conf"