Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 1 | require ttf.inc |
| 2 | |
| 3 | SUMMARY = "Adobe Source Code Pro" |
| 4 | HOMEPAGE = "https://github.com/adobe-fonts/source-code-pro" |
| 5 | LICENSE = "OFL-1.1" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c7c16bdc2c96af797293d68503e5c65c" |
| 7 | |
| 8 | inherit allarch fontcache |
| 9 | |
| 10 | SRC_URI = " \ |
| 11 | https://github.com/adobe-fonts/source-code-pro/releases/download/2.030R-ro/1.050R-it/source-code-pro-2.030R-ro-1.050R-it.zip \ |
| 12 | file://44-source-code-pro-fonts-fontconfig.conf \ |
| 13 | " |
| 14 | SRC_URI[sha256sum] = "da2ac159497d31b0c6d9daa8fc390fb8252e75b4a9805ace6a2c9cccaed4932e" |
| 15 | S = "${WORKDIR}/source-code-pro-2.030R-ro-1.050R-it" |
| 16 | |
| 17 | do_install() { |
| 18 | install -d ${D}${sysconfdir}/fonts/conf.d/ |
| 19 | install -m 0644 ${WORKDIR}/44-source-code-pro-fonts-fontconfig.conf ${D}${sysconfdir}/fonts/conf.d/ |
| 20 | |
| 21 | install -d ${D}${datadir}/fonts/truetype/ |
| 22 | find ./ -name '*.otf' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/ \; |
| 23 | } |
| 24 | |
| 25 | FILES_${PN} = " \ |
| 26 | ${sysconfdir}/fonts \ |
| 27 | ${datadir}/fonts \ |
| 28 | " |
| 29 | |