blob: fdc79e81b2ae5365e85893f22bc4a67c3e61af04 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "multi-protocol instant messaging client"
2SECTION = "x11/network"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
Brad Bishop996bc452019-12-02 13:05:15 -05005DEPENDS = "python3 virtual/libintl intltool-native libxml2 gconf glib-2.0-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006
Brad Bishop996bc452019-12-02 13:05:15 -05007inherit autotools gettext pkgconfig gconf perlnative python3native
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008
9SRC_URI = "\
10 ${SOURCEFORGE_MIRROR}/pidgin/pidgin-${PV}.tar.bz2 \
11 file://sanitize-configure.ac.patch \
12 file://purple-OE-branding-25.patch \
13 file://pidgin-cross-python-265.patch \
Brad Bishop996bc452019-12-02 13:05:15 -050014 file://use_py3.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015"
16
Brad Bishop15ae2502019-06-18 21:44:24 -040017SRC_URI[md5sum] = "423403494fe1951e47cc75231f743bb0"
18SRC_URI[sha256sum] = "2747150c6f711146bddd333c496870bfd55058bab22ffb7e4eb784018ec46d8f"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019
20PACKAGECONFIG ??= "gnutls consoleui avahi dbus idn nss \
21 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 gtk startup-notification', '', d)} \
22"
23PACKAGECONFIG[farsight2] = "--enable-farstream,--disable-farstream,farsight2"
24# --disable-gstreamer compile without GStreamer audio support
25# --disable-gstreamer-video
26# compile without GStreamer 1.0 Video Overlay support
27# --disable-gstreamer-interfaces
28# compile without GStreamer 0.10 interface support
29# --with-gstreamer=<version>
30# compile with GStreamer 0.10 or 1.0 interface
31PACKAGECONFIG[gstreamer] = "--enable-gstreamer,--disable-gstreamer,gstreamer"
32PACKAGECONFIG[vv] = "--enable-vv,--disable-vv,gstreamer"
33PACKAGECONFIG[idn] = "--enable-idn,--disable-idn,libidn"
34PACKAGECONFIG[gtk] = "--enable-gtkui,--disable-gtkui,gtk+"
35PACKAGECONFIG[x11] = "--with-x=yes --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--with-x=no,virtual/libx11"
36PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
37PACKAGECONFIG[consoleui] = "--enable-consoleui --with-ncurses-headers=${STAGING_INCDIR},--disable-consoleui,ncurses"
38PACKAGECONFIG[gnutls] = "--enable-gnutls --with-gnutls-includes=${STAGING_INCDIR} --with-gnutls-libs=${STAGING_LIBDIR},--disable-gnutls,gnutls,libpurple-plugin-ssl-gnutls"
39PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus dbus-glib"
40PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
41PACKAGECONFIG[nss] = "--enable-nss,--disable-nss,nss nspr,libpurple-plugin-ssl-nss"
42
43EXTRA_OECONF = " \
44 --disable-perl \
45 --disable-tcl \
46 --disable-gevolution \
47 --disable-schemas-install \
48 --disable-gtkspell \
49 --disable-meanwhile \
50 --disable-nm \
51 --disable-screensaver \
52"
53
54do_configure_prepend() {
55 touch ${S}/po/Makefile
56 sed -i "s#PY_VERSION=`$PYTHON -c 'import sys ; print sys.version[0:3]'`#PY_VERSION=${PYTHON_BASEVERSION}#g" ${S}/configure.ac
57}
58
59OE_LT_RPATH_ALLOW=":${libdir}/purple-2:"
60OE_LT_RPATH_ALLOW[export]="1"
61
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080062PACKAGES =+ "libpurple-dev libpurple libgnt libgnt-dev finch finch-dev ${PN}-data"
63
64RPROVIDES_${PN}-dbg += "libpurple-dbg libgnt-dbg finch-dbg"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050065
66LEAD_SONAME = "libpurple.so.0"
67FILES_libpurple = "${libdir}/libpurple*.so.* ${libdir}/purple-2 ${bindir}/purple-* ${sysconfdir}/gconf/schemas/purple* ${datadir}/purple/ca-certs"
68FILES_libpurple-dev = "${libdir}/libpurple*.la \
69 ${libdir}/libpurple*.so \
70 ${libdir}/purple-2/*.la \
71 ${libdir}/purple-2/libjabber.so \
72 ${libdir}/purple-2/liboscar.so \
73 ${libdir}/purple-2/libymsg.so \
74 ${datadir}/aclocal"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050075FILES_libgnt = "${libdir}/libgnt.so.* ${libdir}/gnt/*.so"
76FILES_libgnt-dev = "${libdir}/gnt/*.la"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050077FILES_finch = "${bindir}/finch"
78FILES_finch-dev = "${libdir}/finch/*.la"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050079
80FILES_${PN} = "${bindir} ${datadir}/${PN} ${libdir}/${PN}/*.so \
81 ${datadir}/applications"
82RRECOMMENDS_${PN} = "${PN}-data libpurple-protocol-irc libpurple-protocol-xmpp"
83
84FILES_${PN}-data = "${datadir}/pixmaps ${datadir}/sounds ${datadir}/icons ${datadir}/appdata"
85FILES_${PN}-dev += "${libdir}/${PN}/*.la"
86
87PACKAGES_DYNAMIC += "^libpurple-protocol-.* ^libpurple-plugin-.* ^pidgin-plugin-.* ^finch-plugin-.*"
88
89python populate_packages_prepend () {
90 pidgroot = d.expand('${libdir}/pidgin')
91 purple = d.expand('${libdir}/purple-2')
92 finch = d.expand('${libdir}/finch')
93
94 do_split_packages(d, pidgroot, '^([^l][^i][^b].*)\.so$',
95 output_pattern='pidgin-plugin-%s',
96 description='Pidgin plugin %s',
97 prepend=True, extra_depends='')
98
99 do_split_packages(d, purple, '^lib(.*)\.so$',
100 output_pattern='libpurple-protocol-%s',
101 description='Libpurple protocol plugin for %s',
102 prepend=True, extra_depends='')
103
104 do_split_packages(d, purple, '^(ssl-.*)\.so$',
105 output_pattern='libpurple-plugin-%s',
106 description='libpurple plugin %s',
107 prepend=True, extra_depends='libpurple-plugin-ssl')
108
109 do_split_packages(d, purple, '^([^l][^i][^b].*)\.so$',
110 output_pattern='libpurple-plugin-%s',
111 description='libpurple plugin %s',
112 prepend=True, extra_depends='')
113
114 do_split_packages(d, finch, '^([^l][^i][^b].*)\.so$',
115 output_pattern='finch-plugin-%s',
116 description='Finch plugin %s',
117 prepend=True, extra_depends='')
118}